Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / lyx / lyx_1.6.1.bb
1 DESCRIPTION = "LyX is an advanced type setting processor - a frontend for LaTeX"
2 SECTION = "x11/office"
3 LICENSE = "GPL"
4 HOMEPAGE = "http://www.lyx.org"
5 DEPENDS = "qt4-x11-free"
6 RSUGGESTS = "tetex"
7 RDEPENDS = "python-shell python-textutils"
8 PR = "r0"
9
10 SRC_URI = "\
11   ftp://ftp.lyx.org/pub/lyx/stable/1.6.x/lyx-${PV}.tar.bz2 \
12   file://no-session-manager.patch;patch=1 \
13 "
14
15 inherit qt4x11 autotools
16
17 EXTRA_OECONF = "\
18   --with-qt4-dir=${QTDIR} \
19   --enable-threads=posix \
20 "
21
22 EXTRA_QMAKEVARS_POST = "DEFINES+=_LIBC"
23 PARALLEL_MAKE = ""
24
25 do_configure() {
26         gnu-configize
27         oe_runconf
28 }