virtual/gail: Introduction of new virtual:
[vuplus_openembedded] / recipes / ltp / ltp_20090131.bb
1 DESCRIPTION = "Linux Test Project"
2 HOMEPAGE = "http://ltp.sourceforge.net"
3 LICENSE = "GPL"
4 SECTION = "console/utils"
5 DEPENDS = "zip-native"
6 PR = "r3"
7
8 inherit autotools
9
10 SRC_URI = "${SOURCEFORGE_MIRROR}/ltp/ltp-full-${PV}.tgz \
11            file://cross-compile.patch;patch=1 \
12            file://runltp-path.patch;patch=1 \
13            file://fix-tcore_patch_test_suites.patch;patch=1 \
14            file://no-IDcheck.patch;patch=1 \
15            file://no_hyperthreading_tests.patch;patch=1"
16
17 SRC_URI_append_mips += "file://no_epoll_create2_mips.patch;patch=1"
18 SRC_URI_append_mipsel += "file://no_epoll_create2_mips.patch;patch=1"
19
20 S = "${WORKDIR}/ltp-full-${PV}"
21
22 EXTRA_OEMAKE_append = " CROSS_COMPILE=${HOST_PREFIX}"
23
24 FILES_${PN}-dbg  = "${libexecdir}/ltp/*/*/*/*/*/*/*/*/*/.debug"
25 FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/*/*/*/*/.debug"
26 FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/*/*/*/.debug"
27 FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/*/*/.debug"
28 FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/*/.debug"
29 FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/.debug"
30 FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/.debug"
31 FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/.debug"
32 FILES_${PN}-dbg += "${libexecdir}/ltp/*/.debug"
33
34 TARGET_CC_ARCH += "${LDFLAGS}"
35
36 do_compile(){
37         oe_runmake CROSS_COMPILE=${HOST_PREFIX}
38 }
39
40 do_install(){
41         export CREATE=0
42         export LTPROOT=${D}/usr/libexec/ltp/testcases
43
44         oe_runmake DESTDIR=${D} PREFIX=/usr/libexec/ltp install
45
46         install -d ${D}/usr/libexec/ltp/testcases
47         install -d ${D}/usr/libexec/ltp/pan
48
49         #install testcases 
50         #install -m 0755 ${WORKDIR}/testcases ${D}/usr/libexec/ltp/testcases
51         #install -m 0755 ${WORKDIR}/testcases ${D}/usr/libexec/ltp/
52         
53         # treecopy testcases pan/pan runtest ver_linux IDcheck.sh \
54         # ${D}/usr/libexec/ltp
55         cp testcases    ${D}/usr/libexec/ltp/ -rfp
56         rm              ${D}/usr/libexec/ltp/testcases/ballista -rf
57         cp pan/pan      ${D}/usr/libexec/ltp/pan -p
58         cp runtest      ${D}/usr/libexec/ltp/ -rfp
59         cp ver_linux    ${D}/usr/libexec/ltp/ -p
60         cp runltp       ${D}/usr/libexec/ltp/ -p
61         cp IDcheck.sh   ${D}/usr/libexec/ltp/ -p
62
63         # We don't want "devel" stuff
64         rm -rf ${D}/opt/ltp/include
65         rm ${D}/usr/libexec/ltp/share/pkgconfig/ltp.pc
66 }
67