Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / ltp / ltp_20080229.bb
1 DESCRIPTION = "Linux Test Project"
2 HOMEPAGE = "http://ltp.sourceforge.net"
3 LICENSE = "GPL"
4 SECTION = "console/utils"
5
6 SRC_URI = "${SOURCEFORGE_MIRROR}/ltp/ltp-full-${PV}.tgz \
7            file://cross-compile.patch;patch=1 \
8            file://runltp-path.patch;patch=1 \
9            file://ltp-run \
10            file://posix_shell_compat.patch;patch=1 \
11            file://ballista.patch;patch=1"
12
13 S = "${WORKDIR}/ltp-full-${PV}"
14
15 EXTRA_OEMAKE_append = " CROSS_COMPILE=${HOST_PREFIX}"
16
17 FILES_${PN}-dbg =  "${libexecdir}/ltp/*/*/*/*/*/.debug"
18 FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/*/.debug"
19 FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/*/.debug"
20 FILES_${PN}-dbg += "${libexecdir}/ltp/*/*/.debug"
21 FILES_${PN}-dbg += "${libexecdir}/ltp/*/.debug"
22 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/trigo/.debug"
23 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/iperb/.debug"
24 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/exp_log/.debug"
25 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/power/.debug"
26 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/float/bessel/.debug"
27 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/abs/.debug"
28 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/atof/.debug"
29 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/nextafter/.debug"
30 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/math/fptests/.debug"
31 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/f00f/.debug"
32 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/misc/crash/.debug"
33 #FILES_${PN}-dbg += "${libexecdir}/ltp/pan/.debug"
34 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/network/ipv6/*/.debug"
35 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/network/rpc/rpc01/.debug"
36 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/bin/.debug"
37 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/kernel/syscalls/*/.debug"
38 #FILES_${PN}-dbg += "${libexecdir}/ltp/testcases/kernel/mem/*/.debug"
39
40 do_compile(){
41         oe_runmake CROSS_COMPILE=${HOST_PREFIX}
42 }
43
44 do_install(){
45         export CREATE=0
46         export LTPROOT=${D}/usr/libexec/ltp/testcases
47
48         oe_runmake install
49
50         install -d ${D}/usr/libexec/ltp/testcases
51         install -d ${D}/usr/libexec/ltp/pan
52
53         #install testcases 
54         #install -m 0755 ${WORKDIR}/testcases ${D}/usr/libexec/ltp/testcases
55         #install -m 0755 ${WORKDIR}/testcases ${D}/usr/libexec/ltp/
56         
57         # treecopy testcases pan/pan runtest ver_linux IDcheck.sh \
58         # ${D}/usr/libexec/ltp
59         cp testcases    ${D}/usr/libexec/ltp/ -rfp
60         rm              ${D}/usr/libexec/ltp/ballista -rf
61         cp pan/pan      ${D}/usr/libexec/ltp/pan -p
62         cp runtest      ${D}/usr/libexec/ltp/ -rfp
63         cp ver_linux    ${D}/usr/libexec/ltp/ -p
64         cp runltp       ${D}/usr/libexec/ltp/ -p
65         cp IDcheck.sh   ${D}/usr/libexec/ltp/ -p
66 }
67