increase dvbapp PR.
[vuplus_openembedded] / recipes / llvm / llvm-gcc4-cross_svn.bb
1 DESCRIPTION = "The Low Level Virtual Machine - gcc4 frontend"
2 HOMEPAGE = "http://llvm.org"
3 LICENSE = "various"
4
5 DEPENDS = "llvm2.5-native"
6
7 PV = "2.1+svnr${SRCPV}"
8
9 PR = "r1"
10
11 inherit autotools cross
12
13 SRC_URI = "svn://anonsvn.opensource.apple.com/svn/llvm/;module=trunk \
14            "
15            
16 S = "${WORKDIR}/trunk"
17
18 EXTRA_OECONF = "--disable-shared \
19                 --enable-llvm=/data/build/koen/OE/build/tmp/angstrom/work/i686-linux/llvm-native-2.0-r0/llvm-2.0 \
20                "
21
22 do_configure() {
23         gnu-configize
24         libtoolize --force
25         oe_runconf
26 }       
27
28 PARALLEL_MAKE = ""
29
30 #oe_runmake gets distracted by GNUMakefiles...
31 # we also need to get an install.sh and config-ml.in in gcc/ as well somehow
32 do_compile_prepend() {
33         rm -f ${S}/GNUmakefile
34 }