change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / lirc / lirc-modules_0.8.5.bb
1 DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls. This package contains the lirc kernel modules."
2 SECTION = "base"
3 PRIORITY = "optional"
4 HOMEPAGE = "http://www.lirc.org"
5 LICENSE = "GPL"
6 DEPENDS = "virtual/kernel fakeroot-native setserial"
7
8 SRCDATE=${@bb.data.getVar('PV', d, 1)[9:]}
9
10 SRC_URI = "${SOURCEFORGE_MIRROR}/lirc/lirc-${PV}.tar.gz"
11 S = "${WORKDIR}/lirc-${PV}"
12
13
14 inherit autotools module
15
16 require lirc-config.inc
17
18 MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make V=1' -C drivers"
19
20 fakeroot do_install() {
21         oe_runmake -C drivers DESTDIR="${D}" moduledir="/lib/modules/${KERNEL_VERSION}/lirc" install
22         rm -rf ${D}/dev
23 }
24
25 # this is for distributions that don't use udev
26 pkg_postinst_append() {
27 if [ ! -c $D/dev/lirc -a ! -f /sbin/udevd ]; then mknod $D/dev/lirc c 61 0; fi
28 }
29
30 FILES_${PN} = "/lib/modules"