dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / lirc / lirc-modules_0.8.3+cvs20081230.bb
1 DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls. This package contains the lirc kernel modules."
2 SECTION = "base"
3 PRIORITY = "optional"
4 HOMEPAGE = "http://www.lirc.org"
5 LICENSE = "GPL"
6 DEPENDS = "virtual/kernel fakeroot-native setserial"
7 PR = "r0"
8
9 SRCDATE=${@bb.data.getVar('PV', d, 1)[9:]}
10
11 SRC_URI = "cvs://anonymous@lirc.cvs.sourceforge.net/cvsroot/lirc;module=lirc;method=pserver;cvsdate=${SRCDATE}"
12 S = "${WORKDIR}/lirc"
13
14
15 inherit autotools module
16
17 require lirc-config.inc
18
19 MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make V=1' -C drivers"
20
21 fakeroot do_install() {
22         oe_runmake -C drivers DESTDIR="${D}" moduledir="/lib/modules/${KERNEL_VERSION}/lirc" install
23         rm -rf ${D}/dev
24 }
25
26 # this is for distributions that don't use udev
27 pkg_postinst_append() {
28 if [ ! -c $D/dev/lirc -a ! -f /sbin/udevd ]; then mknod $D/dev/lirc c 61 0; fi
29 }
30
31 FILES_${PN} = "/lib/modules"