increase dvbapp PR.
[vuplus_openembedded] / recipes / linux-libc-headers / linux-libc-headers_2.6.8.1.bb
1 require linux-libc-headers.inc
2
3 HOMEPAGE = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/"
4 # license note from the package:
5 #   Linux-libc-headers are derived from linux kernel headers. For license of a
6 #   particular header, check it's content, and if copyright notice isn't present,
7 #   standard linux kernel license applies.
8 # since we assume GPL for linux i think we can also assume it here
9 INHIBIT_DEFAULT_DEPS = "1"
10 PR = "r8"
11
12 # NOTE: no need to package these headers, since the c library includes them.
13 PACKAGES = ""
14
15 SRC_URI = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/linux-libc-headers-${PV}.tar.bz2 \
16         file://mips-asm-atomic-system.diff;patch=1;pnum=0 \
17         file://keyboard.patch;patch=1"
18
19 S = "${WORKDIR}/linux-libc-headers-${PV}"
20
21 do_configure () {
22         case ${TARGET_ARCH} in
23                 alpha*)   ARCH=alpha ;;
24                 arm*)     ARCH=arm ;;
25                 cris*)    ARCH=cris ;;
26                 hppa*)    ARCH=parisc ;;
27                 i*86*)    ARCH=i386 ;;
28                 ia64*)    ARCH=ia64 ;;
29                 mips*)    ARCH=mips ;;
30                 m68k*)    ARCH=m68k ;;
31                 powerpc*) ARCH=ppc ;;
32                 s390*)    ARCH=s390 ;;
33                 sh*)      ARCH=sh ;;
34                 sparc64*) ARCH=sparc64 ;;
35                 sparc*)   ARCH=sparc ;;
36                 x86_64*)  ARCH=x86_64 ;;
37         esac
38         if test !  -e include/asm-$ARCH; then
39                 oefatal unable to create asm symlink in kernel headers
40         fi
41         cp -pPR "include/asm-$ARCH" "include/asm"
42         if test "$ARCH" = "arm"; then
43                 cp -pPR include/asm/arch-ebsa285 include/asm/arch
44         elif test "$ARCH" = "sh"; then
45                 cp -pPR include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
46         fi
47 }
48
49 do_stage () {
50         install -d ${STAGING_INCDIR}
51         rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm
52         cp -pfLR include/linux ${STAGING_INCDIR}/
53         cp -pfLR include/asm ${STAGING_INCDIR}/
54 }