Merge commit 'origin/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / linux / openezx-kernel_git.bb
1 DESCRIPTION = "OpenEZX 2.6 Linux Development Kernel for the Motorola EZX GSM phones"
2 AUTHOR = "The OpenEZX Team <openezx-devel@lists.openezx.org>"
3 HOMEPAGE = "http://www.openezx.org"
4 KV = "2.6.29+2.6.30rc2"
5 PV = "${KV}+gitr${SRCREV}"
6 PR = "r3"
7
8 require linux.inc
9
10 # Make sure not to use thumb[-interworking]
11 ARM_INSTRUCTION_SET = "arm"
12 THUMB_INTERWORKING = "no"
13
14 SRC_URI = "\
15   git://git.openezx.org/openezx.git;protocol=git;branch=ezx/current \
16 "
17 S = "${WORKDIR}/git"
18
19 ##############################################################
20 # The kernel image used to reside on a seperate flash partition
21 # It can be flashed from userspace, so we should package it anyways
22 # (flash_unlock /dev/mtdX && flash_eraseall /dev/mtdX && flashcp /boot/zImage /dev/mtdX)
23
24 COMPATIBLE_HOST = "arm.*-linux"
25 COMPATIBLE_MACHINE = '(a780|e680|a910|a1200|rorkre2|rokre6)'
26
27 # The Kernel command line parameters are given via boot_usb or gen-blob
28
29 ###############################################################
30 # module configs specific to this kernel
31 #
32 #module_autoload_pxaficp_ir = "pxaficp_ir"
33 #module_autoload_snd-pcm-oss = "snd-pcm-oss"
34
35 do_configure_prepend() {
36         install -m 0644 ${S}/arch/arm/configs/ezx_defconfig ${WORKDIR}/defconfig
37 }