enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / linux / linux_2.6.25.bb
1 require linux.inc
2
3 PR = "r8"
4
5 # Mark archs/machines that this kernel supports
6 DEFAULT_PREFERENCE = "-1"
7 DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
8 DEFAULT_PREFERENCE_mpc8315e-rdb = "1"
9 DEFAULT_PREFERENCE_kilauea = "1"
10 DEFAULT_PREFERENCE_sequoia = "1"
11 DEFAULT_PREFERENCE_cm-x270 = "-1"
12 DEFAULT_PREFERENCE_alix = "1"
13 DEFAULT_PREFERENCE_at32stk1000 = "1"
14 DEFAULT_PREFERENCE_at91-l9260 = "1"
15 DEFAULT_PREFERENCE_m8050 = "1"
16 DEFAULT_PREFERENCE_ronetix-pm9263 = "1"
17 DEFAULT_PREFERENCE_ronetix-pm9261 = "1"
18
19 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.25.tar.bz2 \
20            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.20.bz2;patch=1 \
21            file://defconfig"
22
23 SRC_URI_append_mpc8313e-rdb = "\
24         file://mpc831x-nand.patch;patch=1 \
25         file://mpc8313e-rdb-leds.patch;patch=1 \
26         file://mpc8313e-rdb-cardbus.patch;patch=1 \
27         "
28
29 SRC_URI_append_cm-x270 = " \
30         file://0001-cm-x270-match-type.patch;patch=1 \
31         file://0002-ramdisk_load.patch;patch=1 \
32         file://0003-mmcsd_large_cards-r0.patch;patch=1 \
33         file://0004-cm-x270-nand-simplify-name.patch;patch=1 \
34         file://0005-add-display-set-default-16bpp.patch;patch=1 \
35         "
36
37 SRC_URI_append_at32stk1000 = " \
38         http://avr32linux.org/twiki/pub/Main/LinuxPatches/linux-2.6.25.6.atmel.1.patch.bz2;patch=1 \
39         file://virtualmouse.patch;patch=1 \
40 #    file://pll1.diff;patch=1 \
41 "
42
43 SRC_URI_append_at91-l9260 = " \
44         http://maxim.org.za/AT91RM9200/2.6/2.6.25-at91.patch.gz;patch=1 \
45 "
46
47 SRC_URI_append_ronetix-pm9263 = " \
48         http://maxim.org.za/AT91RM9200/2.6/2.6.25-at91.patch.gz;patch=1 \
49         http://download.ronetix.info/sk-eb926x/linux/kernel/2.6.25.4/linux-2.6.25.4-ronetix-08-11-02.2228.patch;patch=1 \
50         http://download.ronetix.info/sk-eb926x/linux/kernel/2.6.25.4/socketcan-driver-at91.patch;patch=1 \
51 "
52
53 SRC_URI_append_ronetix-pm9261 = " \
54         http://maxim.org.za/AT91RM9200/2.6/2.6.25-at91.patch.gz;patch=1 \
55         http://download.ronetix.info/sk-eb926x/linux/kernel/2.6.25.4/linux-2.6.25.4-ronetix-08-11-02.2228.patch;patch=1 \
56         http://download.ronetix.info/sk-eb926x/linux/kernel/2.6.25.4/socketcan-driver-at91.patch;patch=1 \
57 "
58
59 SRC_URI_append_m8050 = " file://m8050.diff;patch=1 file://update-mach-types.diff;patch=1"
60
61 CMDLINE_cm-x270 = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=1 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"
62
63 FILES_kernel-image_cm-x270 = ""
64
65 python do_compulab_image() {
66         import os
67         import os.path
68         import struct
69
70         machine = bb.data.getVar('MACHINE', d, 1)
71         if machine == "cm-x270":
72             deploy_dir = bb.data.getVar('DEPLOY_DIR_IMAGE', d, 1)
73             kernel_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.bin')
74             img_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270')
75
76             fo = open(img_file, 'wb')
77
78             image_data = open(kernel_file, 'rb').read()
79
80             # first write size into first 4 bytes
81             size_s = struct.pack('i', len(image_data))
82
83             # truncate size if we are running on a 64-bit host
84             size_s = size_s[:4]
85
86             fo.write(size_s)
87             fo.write(image_data)
88             fo.close()
89
90             os.chdir(deploy_dir)
91             link_file = bb.data.expand('${KERNEL_IMAGE_SYMLINK_NAME}', d) + '.cmx270'
92             img_file = bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270'
93             try:
94                 os.unlink(link_file)
95             except:
96                 pass
97             os.symlink(img_file, link_file)
98 }
99
100
101 addtask compulab_image after do_deploy before do_package
102