enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / linux / linux_2.6.24.bb
1 require linux.inc
2
3 # Mark archs/machines that this kernel supports
4 DEFAULT_PREFERENCE = "-1"
5 DEFAULT_PREFERENCE_gesbc-9302 = "1"
6 DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
7 DEFAULT_PREFERENCE_simpad = "1"
8 DEFAULT_PREFERENCE_atngw100 = "1"
9 DEFAULT_PREFERENCE_at32stk1000 = "1"
10 DEFAULT_PREFERENCE_ts72xx = "1"
11 DEFAULT_PREFERENCE_hipox = "1"
12 DEFAULT_PREFERENCE_cs-e9302 = "1"
13 DEFAULT_PREFERENCE_smartq5 = "1"
14
15 PR = "r34"
16
17 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
18            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.7.bz2;patch=1 \
19            file://squashfs-lzma-2.6.24.patch;patch=1 \
20            file://ubifs-v2.6.24.patch;patch=1 \
21            file://defconfig"
22
23 # Moved away temporarely until committed properly (work in progress).
24 #           file://powerpc-clockres.patch;patch=1 \
25 #           file://leds-cpu-activity.patch;patch=1 \
26 #           file://leds-cpu-activity-powerpc.patch;patch=1 \
27
28 SRC_URI_append_simpad = "\
29            file://linux-2.6.24-SIMpad-GPIO-MMC-mod.patch;patch=1 \
30            file://linux-2.6.24-SIMpad-battery-old-way-but-also-with-sysfs.patch;patch=1 \
31            file://linux-2.6.24-SIMpad-cs3-simpad.patch;patch=1 \
32            file://linux-2.6.24-SIMpad-mq200.patch;patch=1 \
33            file://linux-2.6.24-SIMpad-pcmcia.patch;patch=1 \
34            file://linux-2.6.24-SIMpad-serial-gpio_keys-and-cs3-ro.patch.v2;patch=1 \ 
35            file://linux-2.6.24-SIMpad-ucb1x00-switches.patch;patch=1 \
36            file://linux-2.6.24-SIMpad-ucb1x00-ts-supend-and-accuracy.patch;patch=1 \
37            file://linux-2.6.24-SIMpad-hostap_cs-shared-irq.patch;patch=1 \
38            file://linux-2.6.24-SIMpad-orinoco_cs-shared-irq.patch;patch=1 \ 
39            file://linux-2.6.24-SIMpad-rtc-sa1100.patch;patch=1 \
40            file://linux-2.6.24-SIMpad-ucb1x00-audio.patch;patch=1 \
41            file://connectplus-remove-ide-HACK.patch;patch=1 \
42            file://collie-kexec.patch;patch=1 \
43            file://export_atags-r2.patch;patch=1 \
44            "       
45
46 SRC_URI_append_gesbc-9302 = " \
47         file://0001-gesbc-nand.patch;patch=1 \
48         file://0002-gesbc-eth-platform.patch;patch=1 \
49         file://0005-ep93xx-reboot.patch;patch=1 \
50         "
51
52 SRC_URI_append_mpc8313e-rdb = "\
53         file://mpc831x-nand.patch;patch=1 \
54         file://mpc8313e-rdb-leds.patch;patch=1 \
55         file://mpc8313e-rdb-rtc.patch;patch=1 \
56         file://mpc8313e-rdb-cardbus.patch;patch=1 \
57         "
58
59 CMDLINE_gesbc-9302 = "console=ttyAM0 root=mtd5 rootfstype=jffs2 mtdparts=GESBC-NAND:64m(app),-(data)"
60
61 SRC_URI_append_cm-x270 = " \
62         file://0001-cm-x270-match-type.patch;patch=1 \
63         file://0002-ramdisk_load.patch;patch=1 \
64         file://0003-mmcsd_large_cards-r0.patch;patch=1 \
65         file://0004-cm-x270-nand-simplify-name.patch;patch=1 \
66         file://0005-add-display-set-default-16bpp.patch;patch=1 \
67         "
68
69 SRC_URI_avr32 = "http://avr32linux.org/twiki/pub/Main/LinuxPatches/linux-2.6.24.3.atmel.3.tar.bz2 \
70                  file://defconfig"
71 S_avr32 = "${WORKDIR}/linux-2.6.24.3.atmel.3"
72
73 SRC_URI_append_ts72xx = "\
74         file://ep93xx-gpio-interrupt-debounce.diff;patch=1 \
75         file://ep93xx-i2c-bus.diff;patch=1 \
76         file://ep93xx-i2c.diff;patch=1 \
77         file://ep93xx-leds.diff;patch=1 \
78         file://ep93xx-serial-uartbaud.diff;patch=1 \
79         file://ep93xx-serial-clocks.diff;patch=1 \
80         file://ep93xx-timer-accuracy.diff;patch=1 \
81         file://ep93xx-maverick-uniqid.patch;patch=1 \
82         file://ep93xx-eth-phylib-framework.patch;patch=1 \
83         file://ts72xx-nfbit-fix.patch;patch=1 \
84         file://ts72xx-machine-id-fix.patch;patch=1 \
85         file://ts72xx-watchdog.patch;patch=1 \
86         file://ts72xx-use-cpld-reset.patch;patch=1 \
87         file://ts72xx-rs485.patch;patch=1"
88
89 SRC_URI_append_hipox = " \
90         file://hipox-mach-type.patch;patch=1 \
91         file://hipox.patch;patch=1 \
92         file://hipox-uart.patch;patch=1 \
93         file://hipox-pci-config-delay.patch;patch=1 \
94         file://hipox-pci-max-size.patch;patch=1 \
95         file://hipox-nand.patch;patch=1 \
96         file://hipox-ubifs.patch;patch=1 \
97         file://hipox-kconfig.patch;patch=1 \
98         file://hipox-sata-module.patch;patch=1 \
99         file://hipox-OXE-INT2.patch;patch=1 \
100         file://hipox-rtc.patch;patch=1 \
101         file://hipox-nand-vs-pci.patch;patch=1 \
102         file://hipox-nand-vs-nor.patch;patch=1 \
103         "
104
105 EXTRA_OEMAKE_smartq5 = " OBJCOPY=${OBJCOPY}"
106 SRC_URI_smartq5 = " ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
107     http://ftp.kernel.org/pub/linux/kernel/v2.6/patch-2.6.24.7.bz2;patch=1 \
108     file://smartq-gitupdate.diff;patch=1 \
109     file://base/0001-Apply-samsung-kernel-patch.patch;patch=1 \
110     file://base/0002-Apply-smartq-patch.patch;patch=1 \
111     file://mer/0001-Mer-keymappings-change.patch;patch=1 \
112     file://mer/0002-no-DM9000.patch;patch=1 \
113     file://mer/0003-Mer-WPA-fix.patch;patch=1 \
114     file://mer/0004-Mer-hardwire-USB-OTG-gadget-type.patch;patch=1 \
115     file://mer/0005-backlight-parameter-and-fixes.patch;patch=1 \
116     file://mer/0006-tv-encoder.patch;patch=1 \
117     file://mer/0007-make-tv-encoder-scaler-compile.patch;patch=1 \
118     file://mer/0008-build-TV-by-default.patch;patch=1 \
119     file://mer/0009-Apply-cpufreq-patch-from-gqwang.patch;patch=1 \
120     file://mer/0010-Better-compatibility-with-some-memory-chips.patch;patch=1 \
121     file://mer/0011-Only-reserve-memory-for-TV-if-CONFIG_VIDEO_SAMSUNG_T.patch;patch=1 \
122     file://mer/0012-Disable-TV-out-to-save-RAM.patch;patch=1 \
123     file://defconfig \
124 "
125
126
127 CMDLINE_cm-x270 = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=1 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"
128
129 FILES_kernel-image_gesbc-9302 = ""
130
131 python do_compulab_image() {
132         import os
133         import os.path
134         import struct
135
136         machine = bb.data.getVar('MACHINE', d, 1)
137         if machine == "cm-x270":
138             deploy_dir = bb.data.getVar('DEPLOY_DIR_IMAGE', d, 1)
139             kernel_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.bin')
140             img_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270')
141
142             fo = open(img_file, 'wb')
143
144             image_data = open(kernel_file, 'rb').read()
145
146             # first write size into first 4 bytes
147             size_s = struct.pack('i', len(image_data))
148
149             # truncate size if we are running on a 64-bit host
150             size_s = size_s[:4]
151
152             fo.write(size_s)
153             fo.write(image_data)
154             fo.close()
155
156             os.chdir(deploy_dir)
157             link_file = bb.data.expand('${KERNEL_IMAGE_SYMLINK_NAME}', d) + '.cmx270'
158             img_file = bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270'
159             try:
160                 os.unlink(link_file)
161             except:
162                 pass
163             os.symlink(img_file, link_file)
164 }
165
166
167 addtask compulab_image after do_deploy before do_package_write
168