enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / linux / linux_2.6.18.bb
1 # Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
2 # Released under the MIT license (see packages/COPYING)
3
4 require linux.inc
5
6 DEFAULT_PREFERENCE = "-1"
7 DEFAULT_PREFERENCE_avr32 = "1"
8
9 PR = "r1"
10
11 PARALLEL_MAKE=""
12
13 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
14            ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.8.bz2;patch=1 \
15            file://defconfig \
16            " 
17
18 SRC_URI_append_avr32 = " \
19            file://atmel-version.patch;patch=1 \
20            file://add-flush_buffer-operation-to-uart_ops.patch;patch=1 \
21            file://kbuild-add-unifdef.patch;patch=1 \
22            file://kbuild-replace-use-of-strlcpy-with-a-dedicated-implmentation-in-unifdef.patch;patch=1 \
23            file://kbuild-use-in-kernel-unifdef.patch;patch=1 \
24            file://spi-set-kset-of-master-class-dev-explicitly.patch;patch=1 \
25            file://spi-fix-spi-busnum-to-master-buffer-and-bus_num-0.patch;patch=1 \
26            file://usb-ethernet-align-all-descriptors-on-a-word-boundary.patch;patch=1 \
27            file://usb-ethernet-define-cdc-capability-for-husb2.patch;patch=1 \
28            file://usb-file-storage-align-all-descriptors-on-a-word-boundary.patch;patch=1 \
29            file://usb-serial-align-all-descriptors-on-a-word-boundary.patch;patch=1 \
30            file://usb-zero-align-all-descriptors-on-a-word-boundary.patch;patch=1 \
31            file://dont-include-map-h-from-physmap-h.patch;patch=1 \
32            file://mtd-unlock-nor-flash-automatically-where-necessary.patch;patch=1 \
33            file://avr32-arch.patch;patch=1 \
34            file://avr32-dont-include-asm-delay-h.patch;patch=1 \
35            file://avr32-unistd-h-move-ifdef-kernel.patch;patch=1 \
36            file://avr32-checkstack.patch;patch=1 \
37            file://avr32-oprofile.patch;patch=1 \
38            file://avr32-drop-GFP_COMP-for-DMA-memory-allocations.patch;patch=1 \
39            file://avr32-move-ethernet-tag-parsing-to-board-specific-code.patch;patch=1 \
40            file://avr32-dma-controller-framework.patch;patch=1 \
41            file://avr32-arch-neutral-gpio-api.patch;patch=1 \
42            file://add-mach-specific-kconfig.patch;patch=1 \
43            file://avr32-gpio-dev.patch;patch=1 \
44            file://atmel-usart3-driver.patch;patch=1 \
45            file://atmel-macb-ethernet-driver.patch;patch=1 \
46            file://at32ap7000-dmac-driver.patch;patch=1 \
47            file://atmel-mmc-host-driver.patch;patch=1 \
48            file://atmel-spi-master-driver.patch;patch=1 \
49            file://atmel-twi-driver.patch;patch=1 \
50            file://atmel-lcdc-framebuffer-driver.patch;patch=1 \
51            file://lcdc-wait-for-vsync.patch;patch=1 \
52            file://ltv350qv-lcd-driver.patch;patch=1 \
53            file://atmel-husb2-udc-driver.patch;patch=1 \
54            file://avr32-sound.patch;patch=1 \
55            file://atmel-ac97c-alsa-driver.patch;patch=1 \
56            file://at73c213-alsa-driver.patch;patch=1 \
57            file://at32-dac-oss-driver.patch;patch=1 \
58            file://renumber-usart-devices.patch;patch=1 \
59            file://rename-ttyUS-to-ttyS-or-ttyAT.patch;patch=1 \
60            file://at32-dac-oss-driver-clk-fix.patch;patch=1 \
61            file://add-all-parameters-to-smc-driver.patch;patch=1 \
62            file://at32ap7000-platform_device-definitions.patch;patch=1 \
63            file://atstk1000-instantiate-devices.patch;patch=1 \
64            file://add-hmatrix-support.patch;patch=1 \
65            file://add-ide-header.patch;patch=1 \
66            file://avr32-network-gateway-support.patch;patch=1 \
67            file://ngw-fix-usart-initialization.patch;patch=1 \
68            file://avr32-little-endian-read-write-bwl.patch;patch=1 \
69            file://gpio-dev-robustness.patch;patch=1 \
70            file://add-intc_pending_irq-to-intc.patch;patch=1 \
71            file://update-atstk1002_defconfig.patch;patch=1 \
72            file://fix-usart3-rx-BUG.patch;patch=1 \
73            file://fix-lcd-display-off-by-two-problem.patch;patch=1 \
74            file://fix-alpha-color-bitfield.patch;patch=1 \
75            file://jffs2_can_mark_obsolete-should-return-0-for-dataflash.patch;patch=1 \
76            file://mtd-fix-atmel-pri-for-cmdset-0001-and-cmdset-0002.patch;patch=1 \
77            file://fix-gpio-prototypes.patch;patch=1 \
78            file://pio-deglitch.patch;patch=1 \
79            file://pio-interrupt-controller.patch;patch=1 \
80            file://gpio-dev-blocking-read.patch;patch=1 \
81            file://add-default-atngw-defconfig.patch;patch=1 \
82            file://gpio-define-pio-none.patch;patch=1 \
83            file://mmc-add-platform-data.patch;patch=1 \
84            file://ngw100-change-spi-clock-on-dataflash.patch;patch=1 \
85            file://atstk1000-add-platform-data-for-mmc.patch;patch=1 \
86            file://avr32-increment-pointer-when-parsing-for-fbmem_start.patch;patch=1 \
87            file://lcdc-do-not-clear-mem-if-fbmem_start-is-set.patch;patch=1 \
88            file://avr32-fix-oprofile-interrupts.patch;patch=1 \
89            file://avr32-time-add-shared-interrupts.patch;patch=1 \
90            file://usart-make-rx-timeout-baudrate-independent.patch;patch=1 \
91            file://spi-reduce-dlybs-and-dlybct.patch;patch=1 \
92            file://dmac-stopping-idle-channel-is-not-fatal.patch;patch=1 \
93            file://mmc-core-dma-fix.patch;patch=1 \
94            file://atstk1000-board-fix-fbmem-setup.patch;patch=1 \
95            file://lcdc-fix-possible-null-pointer-and-match-guard-time-to-uboot.patch;patch=1 \
96            file://ltv350qv-add-initial_power_state-param.patch;patch=1 \
97            file://atmel-mci-debugfs.patch;patch=1 \
98            file://dmac-add-explicit-blockcount-to-dma_request_sg.patch;patch=1 \
99            file://atmel-mci-init-nr_blocks-in-dma-request.patch;patch=1 \
100            file://mmc-add-bit-manipulating-macros.patch;patch=1 \
101            file://mmc-add-detect-card-and-wp-support.patch;patch=1 \
102            file://atmel_spi-handle-rx-overrun.patch;patch=1 \
103            file://atmel_spi-send-zeroes-when-tx_buf-is-not-set.patch;patch=1 \
104            file://husb2_udc-test-mode.patch;patch=1 \
105            file://0001-AVR32-Fix-compile-error-with-gcc-4.1.patch;patch=1 \
106 "
107
108
109 S = "${WORKDIR}/linux-${PV}"
110