enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / linux / linux-storcenter_2.6.27.7.bb
1 DESCRIPTION = "Linux Kernel for the IOMega StorCenter"
2 SECTION = "kernel"
3 LICENSE = "GPL"
4 PR = "r2"
5
6 DEPENDS = "dtc-native"
7 COMPATIBLE_MACHINE = "storcenter"
8
9 SRC_URI = "http://kernel.org/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
10            file://fw-and-powerpc-install.patch;patch=1 \
11            file://defconfig-${PV} \
12                "
13
14 S = "${WORKDIR}/linux-${PV}"
15
16 inherit kernel
17
18 export ARCH="powerpc"
19
20 KERNEL_IMAGETYPE = "uImage"
21
22 FILES_kernel-image += "/boot/storcenter.dtb"
23
24 do_configure() {
25         mkdir -p ${IMAGE_ROOTFS}
26         install -m 0644 ${WORKDIR}/defconfig-${PV} ${S}/.config
27         ARCH=${ARCH} oe_runmake oldconfig
28 }
29
30 do_install_append() {
31         rm -f ${D}/boot/vmlinux-*
32         dtc -f -I dts -O dtb -o ${D}/boot/storcenter.dtb -V 16 ${S}/arch/${ARCH}/boot/dts/storcenter.dts
33 }
34
35 do_builtin_initramfs_foonas() {
36         :
37 }
38
39 pkg_preinst_foonas() {
40         if [ "x$D" != "x" ]; then
41                 ln -sf ${KERNEL_IMAGETYPE}-${PV} ${D}/boot/uImage
42                 exit 1
43         fi
44
45         rm -f /boot/uImage
46         ln -sf ${KERNEL_IMAGETYPE}-${PV} /boot/uImage
47 }
48
49 do_deploy() {
50         install -d ${DEPLOY_DIR_IMAGE}
51         install -m 0644 ${S}/arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/vmlinux.UBoot
52         install -m 0644 ${D}/boot/storcenter.dtb ${DEPLOY_DIR_IMAGE}/storcenter.dtb
53 }
54
55 do_deploy[dirs] = "${S}"
56
57 addtask deploy before do_package after do_install