enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / linux / linux-openmoko-shr-drm-devel_git.bb
1 require linux.inc
2 require linux-openmoko.inc
3
4 DESCRIPTION_${PN} = "Linux ${KERNEL_VERSION} kernel for the Openmoko Neo GSM Smartphones"
5
6 DEFAULT_PREFERENCE = "-1"
7 KERNEL_RELEASE = "2.6.29"
8 KERNEL_VERSION = "2.6.29-rc3-drm"
9
10 OMV = "oe15"
11 PV = "${KERNEL_RELEASE}-drm-${OMV}+gitr${SRCREV}"
12 PR = "r5"
13
14 SRC_URI = "\
15   git://git.openmoko.org/git/kernel.git;protocol=git;branch=drm-tracking \
16   file://fix-install.patch;patch=1 \
17   file://0001-Add-drm-to-Makefile-version.patch;patch=1 \
18   file://0004-gta02_drm_defconfig-start-from-gta02_packaging_defco.patch;patch=1 \
19   file://0005-Enable-DRM-and-MFD_GLAMO_DRM.patch;patch=1 \
20   file://0006-Enable-I2C_ALGOBIT-from-make-oldconfig.patch;patch=1 \
21   file://0007-Enable-UBI-UBIFS.patch;patch=1 \
22 "
23 S = "${WORKDIR}/git"
24
25 CONFIG_NAME_om-gta01 = "gta01_moredrivers_defconfig"
26 CONFIG_NAME_om-gta02 = "gta02_drm_defconfig"
27
28 do_configure_prepend() { 
29         install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
30 }