Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into...
[vuplus_openembedded] / recipes / linux / linux-openmoko-shr-devel_git.bb
1 require linux.inc
2 require linux-openmoko.inc
3
4 DESCRIPTION_${PN} = "Linux ${KERNEL_VERSION} kernel for the Openmoko Neo GSM Smartphones"
5
6 KERNEL_RELEASE = "2.6.29"
7 KERNEL_VERSION = "2.6.29-rc3"
8
9 OMV = "oe11"
10 PV = "${KERNEL_RELEASE}-${OMV}+gitr${SRCREV}"
11 PR = "r3.5"
12
13 SRC_URI = "\
14   git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
15   file://fix-install.patch;patch=1 \
16   file://0007-Enable-UBI-UBIFS.patch;patch=1 \
17 "
18 S = "${WORKDIR}/git"
19
20 CONFIG_NAME_om-gta01 = "gta01_moredrivers_defconfig"
21 CONFIG_NAME_om-gta02 = "gta02_packaging_defconfig"
22 CONFIG_NAME_om-gta03 = "gta03_defconfig"
23
24 do_configure_prepend() { 
25         install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
26 }