virtual/gail: Introduction of new virtual:
[vuplus_openembedded] / recipes / linux / linux-omap_2.6.29.bb
1 require linux.inc
2
3 DESCRIPTION = "Linux kernel for OMAP processors"
4 KERNEL_IMAGETYPE = "uImage"
5
6 COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm|omap3-pandora|overo|omapzoom"
7
8 # This is missing the EHCI patch for beagle
9 DEFAULT_PREFERENCE = "-1"
10
11 SRCREV = "90e758af52ba803cba233fabee81176d99589f09"
12
13 PR = "r4+gitr${SRCREV}"
14
15 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
16            file://defconfig"
17
18 SRC_URI_append = " \
19            file://no-empty-flash-warnings.patch;patch=1 \
20            file://no-cortex-deadlock.patch;patch=1 \
21            file://read_die_ids.patch;patch=1 \
22            file://fix-install.patch;patch=1 \
23            file://DSS2.diff;patch=1 \
24            file://0001-board-ldp-add-regulator-info-to-get-the-microSD-slo.patch;patch=1 \
25            file://fix-unaligned-access.diff;patch=1 \
26            file://make-alignment-visible.diff;patch=1 \
27            file://mmctiming.patch;patch=1 \
28 "
29
30
31 SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \
32                              "
33
34 SRC_URI_append_omap3evm = " \
35         file://evm-mcspi-ts.diff;patch=1 \
36 "
37
38 S = "${WORKDIR}/git"
39
40
41 module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"
42
43