increase dvbapp PR.
[vuplus_openembedded] / recipes / linux / linux-ks8695_2.6.16.bb
1 DESCRIPTION = "Linux kernel for Micrel KS8695(P) based devices"
2 SECTION = "kernel"
3 LICENSE = "GPL"
4 PR = "r0"
5
6 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
7            file://ks8695-headers-r0.patch;patch=1 \
8            file://ks8695-base-r0.patch;patch=1 \
9            file://defconfig-ks8695"
10
11 S = "${WORKDIR}/linux-${PV}"
12
13 COMPATIBLE_HOST = 'arm.*-linux'
14 COMPATIBLE_MACHINE = "ks8695"
15
16 inherit kernel
17 inherit package
18
19 ARCH = "arm"
20 CMDLINE = "ttyS0,115200n8 root=/dev/mtdblock2 init=/linuxrc"
21
22 do_configure_prepend() {
23         install -m 0644 ${WORKDIR}/defconfig-${MACHINE} ${S}/.config
24         echo "CONFIG_CMDLINE=\"${CMDLINE}\"" >> ${S}/.config
25 }