enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / linux / linux-kirkwood_2.6.31.bb
1 DESCRIPTION = "Linux Kernel for Marvell Kirkwood based devices"
2 SECTION = "kernel"
3 LICENSE = "GPL"
4
5 COMPATIBLE_MACHINE = "openrd-base"
6
7 # SheevaPlug still needs testing
8 #COMPATIBLE_MACHINE = "(openrd-base|sheevaplug)"
9
10 require linux.inc
11
12 FILESPATHPKG_prepend = "linux-2.6.31:"
13
14 # Change MACHINE_KERNEL_PR in conf/machine/include/kirkwood.inc
15 PV = "2.6.31"
16
17 # last commit at the time of release of upstream v2.6.31
18 SRCREV = "8cb424312d88810bb62edbeef42a510725ceb482"
19
20 SRC_URI = "git://git.marvell.com/orion.git;protocol=git \
21            file://defconfig"
22
23 SRC_URI_append_openrd-base = " file://openrd-base-enable-pcie.patch;patch=1 \
24                                file://cpuidle-reenable-interrupts.patch;patch=1 \
25                                file://0001-Squashfs-move-zlib-decompression-wrapper-code-into.patch;patch=1 \
26                                file://0002-Squashfs-Factor-out-remaining-zlib-dependencies-int.patch;patch=1 \
27                                file://0003-Squashfs-add-a-decompressor-framework.patch;patch=1 \
28                                file://0004-Squashfs-add-decompressor-entries-for-lzma-and-lzo.patch;patch=1 \
29                                file://0005-Squashfs-add-an-extra-parameter-to-the-decompressor.patch;patch=1 \
30                                file://0006-Squashfs-add-LZMA-compression.patch;patch=1 \
31                                file://0007-Squashfs-Make-unlzma-available-to-non-initramfs-ini.patch;patch=1 \
32                              "
33 # update machine types list for ARM architecture, only for machines that need it
34 do_arm_mach_types() {
35   if test ${MACHINE} == openrd-base; then
36     curl -o mach-types "http://www.arm.linux.org.uk/developer/machines/download.php" && \
37     cp mach-types arch/arm/tools/mach-types
38   fi
39 }
40
41 addtask arm_mach_types after do_patch before do_configure
42
43 S = "${WORKDIR}/git"
44
45 KERNEL_IMAGETYPE ?= "uImage"