enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / linux / linux-dht-walnut_2.6.23.bb
1 # Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
2 # Released under the MIT license (see packages/COPYING)
3 require linux.inc
4
5 DESCRIPTION = "Linux kernel for DHT-Walnut (ppc)  machine"
6
7 DEFAULT_PREFERENCE = "-1"
8
9 PR = "r0"
10 DEPENDS = "u-boot"
11
12 COMPATIBLE_MACHINE = "dht-walnut"
13
14 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
15            file://defconfig"
16
17 S = "${WORKDIR}/linux-${PV}"
18
19 FILES_kernel-image = "/boot/zImage.elf"
20
21 export OS = "Linux"
22 ARCH = "ppc"
23
24 do_stage_append () {
25 #need ppc platforms includes + friends in order for external kernel modules to compile as headers as still split
26
27        install -d ${STAGING_KERNEL_DIR}/arch/
28        cp -pPR arch/ppc ${STAGING_KERNEL_DIR}/arch/
29        cp -pPR arch/powerpc ${STAGING_KERNEL_DIR}/arch/
30
31        cp -pPR include/asm-powerpc ${STAGING_KERNEL_DIR}/include/
32        cp -pPR include/asm-ppc ${STAGING_KERNEL_DIR}/include/
33 }
34
35 do_install_append () {
36         install -d  ${DEPLOY_DIR_IMAGE}
37         if [ -e arch/ppc/boot/images/zImage.elf ] ; then
38             cp -a arch/ppc/boot/images/zImage.elf arch/ppc/boot/images/zImage
39             install -m 0755 arch/ppc/boot/images/zImage.elf \ 
40                 ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}.elf
41         fi      
42         install -m 0755 vmlinux ${DEPLOY_DIR_IMAGE}/
43 }
44
45
46 pkg_postinst_kernel () {
47         true
48 }
49
50 pkg_postrm_kernel () {
51         true
52 }
53
54
55
56