enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / linux / linux-dht-walnut_2.6.20.bb
1 # Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
2 # Released under the MIT license (see packages/COPYING)
3 require linux.inc
4
5 DESCRIPTION = "Linux kernel for DHT-Walnut (ppc)  machine"
6
7 PR = "r4"
8 DEPENDS = "u-boot"
9
10 COMPATIBLE_MACHINE = "dht-walnut"
11
12 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
13            file://defconfig"
14
15 S = "${WORKDIR}/linux-${PV}"
16
17 FILES_kernel-image = "/boot/zImage.elf"
18
19 export OS = "Linux"
20 ARCH = "ppc"
21
22 do_stage_append () {
23 #need ppc platforms includes + friends in order for external kernel modules to compile as headers as still split
24
25        install -d ${STAGING_KERNEL_DIR}/arch/
26        cp -pPR arch/ppc ${STAGING_KERNEL_DIR}/arch/
27        cp -pPR arch/powerpc ${STAGING_KERNEL_DIR}/arch/
28
29        cp -pPR include/asm-powerpc ${STAGING_KERNEL_DIR}/include/
30        cp -pPR include/asm-ppc ${STAGING_KERNEL_DIR}/include/
31 }
32
33 do_install_append () {
34         install -d  ${DEPLOY_DIR_IMAGE}
35         if [ -e arch/ppc/boot/images/zImage.elf ] ; then
36             cp -a arch/ppc/boot/images/zImage.elf arch/ppc/boot/images/zImage
37             install -m 0755 arch/ppc/boot/images/zImage.elf \ 
38                 ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}.elf
39         fi      
40         install -m 0755 vmlinux ${DEPLOY_DIR_IMAGE}/
41 }
42
43
44 pkg_postinst_kernel () {
45         true
46 }
47
48 pkg_postrm_kernel () {
49         true
50 }
51
52
53
54