Change FPU to hard
[vuplus_openembedded] / recipes / linux / linux-bm750.bb
1 DESCRIPTION = "Linux kernel for vuplus duo"
2 LICENSE = "GPL"
3 KV = "2.6.18-7.3"
4 PV = "2.6.18-7.3"
5 PR = "r4"
6
7 MODULE = "stblinux-2.6.18"
8
9
10 SRC_URI = "http://archive.vuplus.com/download/stblinux-${KV}.tar.bz2 \
11         file://linux_bm750_nand.patch;patch=1;pnum=0 \
12         file://linux_bm750_proc.patch;patch=1;pnum=0 \
13         file://linux_bm750_resource.patch;patch=1;pnum=0 \
14         file://linux_bm750_serial.patch;patch=1;pnum=0 \
15         file://linux_bm750_setup.patch;patch=1;pnum=0 \
16         file://linux_bm750_arch_makefile.patch;patch=1;pnum=0 \
17         file://linux_bm750_kobject.patch;patch=1;pnum=0 \
18         file://linux_bm750_dvb-core_fe.patch;patch=1;pnum=0 \
19         file://bm750_defconfig \
20         "
21
22
23 S = "${WORKDIR}/stblinux-2.6.18"
24
25 inherit kernel
26
27 FILES_kernel-image = "/boot/vmlinux.gz /boot/autoexec.bat"
28
29 export OS = "Linux"
30 KERNEL_IMAGETYPE = "vmlinux"
31 KERNEL_OUTPUT = "vmlinux"
32 KERNEL_OBJECT_SUFFIX = "ko"
33
34
35 do_configure_prepend() {
36         oe_machinstall -m 0644 ${WORKDIR}/bm750_defconfig ${S}/.config
37         if [ -d ${WORKDIR}/cdfs-${PV} ]; then
38                 mv ${WORKDIR}/cdfs-${PV} ${S}/fs/cdfs
39                 cd ${S} & patch -p0 < ${S}/fs/cdfs/patch.cdfs
40         fi;
41         oe_runmake oldconfig
42 }
43
44 do_install_append () {
45         install -d ${D}/boot
46         install -m 0755 vmlinux ${D}/boot/vmlinux
47         gzip ${D}/boot/vmlinux
48 }
49
50 pkg_preinst_kernel-image () {
51         [ -d /proc/stb ] && mount -o rw,remount /boot
52         true
53         if [ -f /boot/vmlinux.gz ];
54         then rm -f /boot/vmlinux.gz;
55         fi
56 }
57
58 pkg_postinst_kernel-image () {
59         if [ -d /proc/stb ];
60         then flash_eraseall /dev/mtd1; nandwrite /dev/mtd1 /boot/vmlinux.gz -p;
61         fi
62         [ -d /proc/stb ] && mount -o ro,remount /boot
63         true
64
65 }
66
67 pkg_prerm_kernel-image () {
68         [ -d /proc/stb ] && mount -o rw,remount /boot
69         true
70 }
71
72 pkg_postrm_kernel-image () {
73         [ -d /proc/stb ] && mount -o ro,remount /boot
74         true
75 }