enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / linux / linux-bd-neon-2.6_2.6.22.bb
1 DESCRIPTION = "2.6 Linux Kernel for Boundary Devices NEON Board"
2 SECTION = "kernel"
3 HOMEPAGE = "N/A"
4 LICENSE = "GPL"
5 COMPATIBLE_MACHINE = "bd-neon"
6 DEPENDS += "u-boot-utils-native"
7
8 PR = "r2"
9
10 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.22.tar.bz2 \
11            http://www.boundarydevices.com/boundary-2.6.22-2007-07-22.patch.bz2;patch=1 \
12            file://neon-jffs2-config.patch;patch=1"
13
14 S = "${WORKDIR}/linux-2.6.22"
15
16 inherit kernel
17
18 KERNEL_IMAGETYPE = "zImage"
19 FILES_kernel-image = ""
20 ALLOW_EMPTY = "1"
21
22 do_configure() {
23         cp arch/arm/configs/neon_defconfig .config || die "No default configuration for ${MACHINE} available."
24
25 #        if [ "${TARGET_OS}" == "linux-gnueabi" -o  "${TARGET_OS}" == "linux-uclibceabi" ]; then
26 #                echo "CONFIG_AEABI=y"                   >> ${S}/.config
27 #                echo "CONFIG_OABI_COMPAT=y"             >> ${S}/.config
28 #        else
29 #                echo "# CONFIG_AEABI is not set"        >> ${S}/.config
30 #                echo "# CONFIG_OABI_COMPAT is not set"  >> ${S}/.config
31 #        fi
32
33         yes '' | oe_runmake oldconfig
34 }
35
36 do_deploy_append() {
37         ${OBJCOPY} -O binary -R .note -R .comment -S vmlinux linux.bin
38         rm -f linux.bin.gz
39         gzip -9 linux.bin
40         ${STAGING_BINDIR_NATIVE}/mkimage -A arm -O linux -T kernel -C gzip -a a0008000 -e a0008000 -n "Boundary Devices NEON" -d linux.bin.gz ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${PR}-${MACHINE}.bin
41         rm -f linux.bin.gz
42 }