add plugin(streamtvplayer)
[vuplus_openembedded] / recipes / linphone / linphone_1.3.99.8.bb
1 DESCRIPTION = "SIP-based IP phone (Console edition)"
2 HOMEPAGE = "http://www.linphone.org/?lang=us"
3 LICENSE = "GPLv2"
4 DEPENDS = "libosip2 speex libogg alsa-lib readline"
5 PR = "r0"
6
7 SRC_URI = "http://download.savannah.nongnu.org/releases/linphone/unstable/source/linphone-${PV}.tar.gz \
8            file://conf.patch;patch=1"
9
10 S = "${WORKDIR}/linphone-${PV}"
11
12 FILES_${PN} += "${datadir}/linphonec"
13
14 inherit autotools
15
16 EXTRA_OECONF = "--disable-gnome_ui --disable-gtk-doc --without-ffmpeg \
17                 --without-sdl --disable-video --enable-alsa \
18                 --with-osip=${STAGING_DIR_HOST}${layout_exec_prefix} \
19                 --with-readline=${STAGING_DIR_HOST}${layout_exec_prefix} \
20                 --with-speex=${STAGING_DIR_HOST}${layout_exec_prefix} \
21                 --disable-truespeech --disable-manual \
22                 --disable-glibtest --disable-glib"
23
24 do_install_append() {
25         rm -f ${D}${datadir}/sounds/linphone/hello*.wav
26         rm -f ${D}${datadir}/sounds/linphone/rings/oldphone.wav
27 }