increase dvbapp PR.
[vuplus_openembedded] / recipes / linphone / linphone-hh_0.12.2.hh1.bb
1 LICENSE = "GPL"
2 SECTION = "x11/utils"
3 PR = "r4"
4
5 DESCRIPTION = "SIP-based IP phone (GPE edition)"
6 DEPENDS = "libosip gtk+ libogg alsa-lib"
7 SRC_URI = "http://handhelds.org/packages/linphone/linphone-${PV}.tar.gz \
8         file://osipua-ipv6-lossage.patch;patch=1 \
9         file://gpe-cross-lossage.patch;patch=1 \
10         file://disable-gtk-doc.patch;patch=1 \
11         file://dotdesktop.patch;patch=1 \
12         file://segfault.patch;patch=1"
13
14 S = "${WORKDIR}/linphone-${PV}"
15
16 FILES_${PN} += "${datadir}/linphonec"
17
18 inherit autotools
19
20 EXTRA_OECONF = "--disable-gnome_ui --disable-gtk-doc"
21
22 do_configure() {
23         # ffmpeg is in AC_SUBDIRS, but doesn't actually use autoconf.
24         # Autoreconf will try to recurse into there and blow up.
25         for dir in . speex oRTP osipua; do
26                 ( cd $dir; libtoolize --force; aclocal; automake; autoconf )
27         done
28
29         oe_runconf
30 }
31
32 do_install_append() {
33         mv ${D}${datadir}/gnome/apps/Internet ${D}${datadir}/applications
34         rm -f ${D}${datadir}/sounds/linphone/hello*.wav
35         rm -f ${D}${datadir}/sounds/linphone/rings/oldphone.wav
36 }