add plugin(streamtvplayer)
[vuplus_openembedded] / recipes / libxsettings-client / libxsettings-client_0.13.bb
1 SECTION = "gpe/libs"
2 LICENSE = "BSD-X"
3 PRIORITY = "optional"
4 DEPENDS = "libgpewidget libxsettings virtual/libx11"
5
6 inherit pkgconfig gpe
7
8 SRC_URI += "file://make_pkgconfig_x11.patch;patch=1"
9
10 headers = "xsettings-client.h"
11 do_stage () {
12         oe_libinstall -so libXsettings-client ${STAGING_LIBDIR}
13         mkdir -p ${STAGING_INCDIR}
14         for h in ${headers}; do
15                 install -m 0644 ${S}/$h ${STAGING_INCDIR}/$h
16         done
17 }
18
19 do_install () {
20         gpe_do_install
21         oe_runmake PREFIX=${prefix} DESTDIR=${D} install-devel
22 }