add plugin(streamtvplayer)
[vuplus_openembedded] / recipes / libtool / libtool-sdk_1.5.10.bb
1 require libtool_${PV}.bb
2
3 PR = "${INC_PR}.0"
4 SRC_URI_append = " file://rpath-control.patch;patch=1 \
5                    file://libdir-la.patch;patch=1 \
6                    file://libdir-la2.patch;patch=1 \
7                    file://prefix.patch;patch=1 \
8                    file://tag.patch;patch=1 \
9                    file://install-path-check.patch;patch=1 \
10                    file://nousrlib.patch;patch=1 \
11                    file://add_sysroot_function.patch;patch=1 \
12                    "
13
14 S = "${WORKDIR}/libtool-${PV}"
15
16 inherit sdk
17
18 do_configure_prepend () {
19         rm -f ltmain.shT
20         date=`/bin/sh ./mkstamp < ./ChangeLog` && \
21         sed -e 's/@''PACKAGE@/libtool/' -e 's/@''VERSION@/1.5.10/' \
22             -e "s%@""TIMESTAMP@%$date%" ./ltmain.in > ltmain.shT
23         mv -f ltmain.shT ltmain.sh || \
24                 (rm -f ltmain.sh && cp ltmain.shT ltmain.sh && rm -f ltmain.shT)
25         cp ltmain.sh ./libltdl/
26 }
27
28 do_install () {
29         install -d ${D}${bindir}/
30         install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/
31         install -m 0755 libtoolize ${D}${bindir}/
32
33         install -d ${D}${libdir}/
34         oe_libinstall -a -so -C libltdl libltdl ${D}${libdir}
35
36         install -d ${D}${includedir}/
37         install -m 0644 libltdl/ltdl.h ${D}${includedir}
38
39         install -d ${D}${datadir}/libtool/
40         install -c config.guess ${D}${datadir}/libtool/
41         install -c config.sub ${D}${datadir}/libtool/
42         install -c -m 0644 ltmain.sh ${D}${datadir}/libtool/
43
44         install -d ${D}${datadir}/info/
45         install -c -m 0644 doc/libtool.info ${D}${datadir}/info/
46
47         install -d ${D}${datadir}/aclocal/
48         install -c -m 0645 libtool.m4 ${D}${datadir}/aclocal/
49         install -c -m 0644 ltdl.m4 ${D}${datadir}/aclocal/
50 }
51