increase dvbapp PR.
[vuplus_openembedded] / recipes / libtool / libtool-cross_2.2.4.bb
1 require libtool_${PV}.bb
2 PR = "${INC_PR}.0"
3
4 SRC_URI += "\
5   file://cross_compile.patch;patch=1 \
6   file://prefix.patch;patch=1 \
7 "
8
9 DEPENDS += "libtool-native"
10
11 DOLT_PATCH = ""
12 DOLT_PATCH_arm = " file://add_dolt.patch;patch=1"
13 DOLT_PATCH_i586 = " file://add_dolt.patch;patch=1"
14
15 #SRC_URI_append_linux = "${DOLT_PATCH}"
16 #SRC_URI_append_linux-gnueabi = "${DOLT_PATCH}"
17
18 S = "${WORKDIR}/libtool-${PV}"
19
20 prefix = "${STAGING_DIR_NATIVE}${prefix_native}"
21 exec_prefix = "${STAGING_DIR_NATIVE}${prefix_native}"
22 bindir = "${STAGING_BINDIR_NATIVE}"
23
24 do_compile () {
25         :
26 }
27
28 do_stage () {
29         install -m 0755 ${HOST_SYS}-libtool ${bindir}/${HOST_SYS}-libtool
30         install -d ${STAGING_DIR_HOST}${target_datadir}/libtool ${STAGING_DIR_HOST}${target_datadir}/aclocal
31         install -c ${S}/libltdl/config/config.guess ${STAGING_DIR_HOST}${target_datadir}/libtool/
32         install -c ${S}/libltdl/config/config.sub ${STAGING_DIR_HOST}${target_datadir}/libtool/
33         install -c -m 0644 ${S}/libltdl/config/ltmain.sh ${STAGING_DIR_HOST}${target_datadir}/libtool/
34         install -c -m 0644 ${S}/libltdl/m4/libtool.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
35         install -c -m 0644 ${S}/libltdl/m4/ltdl.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
36         if [ -e ${WORKDIR}/dolt.m4 ] ; then
37                 install -c -m 0644 ${WORKDIR}/dolt.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
38         fi
39 }
40
41
42 do_install () {
43         :
44 }
45
46 PACKAGES = ""