add plugin(streamtvplayer)
[vuplus_openembedded] / recipes / libtool / libtool-cross_1.5.24.bb
1 require libtool_${PV}.bb
2
3 PR = "${INC_PR}.0"
4 PACKAGES = ""
5 SRC_URI_append = " file://libdir-la.patch;patch=1 \
6                    file://prefix.patch;patch=1 \
7                    file://tag.patch;patch=1 \
8                    file://tag1.patch;patch=1 \
9                    file://install-path-check.patch;patch=1"
10 S = "${WORKDIR}/libtool-${PV}"
11
12 prefix = "${STAGING_DIR_NATIVE}${prefix_native}"
13 exec_prefix = "${STAGING_DIR_NATIVE}${prefix_native}"
14 bindir = "${STAGING_BINDIR_NATIVE}"
15
16 do_compile () {
17         :
18 }
19
20 do_stage () {
21         install -m 0755 ${HOST_SYS}-libtool ${bindir}/${HOST_SYS}-libtool
22         install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/
23         install -d ${STAGING_DIR_HOST}${target_datadir}/libtool ${STAGING_DIR_HOST}${target_datadir}/aclocal
24         install -c config.guess ${STAGING_DIR_HOST}${target_datadir}/libtool/
25         install -c config.sub ${STAGING_DIR_HOST}${target_datadir}/libtool/
26         install -c -m 0644 ltmain.sh ${STAGING_DIR_HOST}${target_datadir}/libtool/
27         install -c -m 0644 libtool.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
28         install -c -m 0644 ltdl.m4 ${STAGING_DIR_HOST}${target_datadir}/aclocal/
29 }
30
31 do_install () {
32         :
33 }