add plugin(streamtvplayer)
[vuplus_openembedded] / recipes / libtomcrypt / libtomcrypt_1.17.bb
1 DESCRIPTION = "LibTomCrypt is a fairly comprehensive, modular \
2 and portable cryptographic toolkit that provides developers \
3 with a vast array of well known published block ciphers, \
4 one-way hash functions, chaining modes, pseudo-random number \
5 generators, public key cryptography and a plethora of other \
6 routines."
7 SECTION = "libs/network"
8 PRIORITY = "optional"
9 LICENSE = "PD"
10 PR = "r0"
11
12 SRC_URI = "http://libtom.org/files/crypt-${PV}.tar.bz2"
13
14 inherit autotools
15
16 EXTRA_OEMAKE = "library"
17
18 #FIXME add patch to make it shared
19
20 do_stage() {
21         oe_libinstall -a libtomcrypt ${STAGING_LIBDIR}/
22         install -m 0644 ${S}/src/headers/*.h ${STAGING_INCDIR}/
23 }
24
25 do_install() {
26         :
27 }