enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / libsigc++-1.2 / libsigc++-1.2_1.2.7.bb
1 DESCRIPTION = "A library for loose coupling of C++ method calls"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 LICENSE = "GPL LGPL"
5 PR = "r0"
6
7 SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libsigc++/1.2/libsigc++-${PV}.tar.bz2 \
8            file://autofoo.patch;patch=1 \
9            file://disable-tests.patch;patch=1"
10 S = "${WORKDIR}/libsigc++-${PV}"
11
12 inherit autotools pkgconfig
13
14 # FIXME: Check why tests don't compile
15
16 acpaths = ""
17
18 do_stage() {
19         install -d ${STAGING_LIBDIR}/sigc++-1.2/include
20         install -m 0644 sigc++/config/sigcconfig.h ${STAGING_LIBDIR}/sigc++-1.2/include/
21         oe_libinstall -so -C sigc++ libsigc-1.2 ${STAGING_LIBDIR}
22
23         install -d ${STAGING_INCDIR}/sigc++-1.2/sigc++
24         for f in sigc++/*.h
25         do
26                 install -m 0644 $f ${STAGING_INCDIR}/sigc++-1.2/sigc++/
27         done
28 }
29
30 FILES_${PN}-dev += "${libdir}/sigc++-*/"