increase dvbapp PR.
[vuplus_openembedded] / recipes / libsigc++-1.2 / libsigc++-1.2_1.2.5.bb
1 DESCRIPTION = "A library for loose coupling of C++ method calls"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 PR = "r1"
5 LICENSE = "GPL LGPL"
6 SRC_URI = "${SOURCEFORGE_MIRROR}/libsigc/libsigc++-${PV}.tar.gz \
7            file://autofoo.patch;patch=1 \
8            file://pkgconfig.patch;patch=1"
9 S = "${WORKDIR}/libsigc++-${PV}"
10
11 inherit autotools pkgconfig
12
13 FILES_${PN}-dev += "${libdir}/sigc++-*/"
14
15 acpaths = ""
16
17 do_stage() {
18         install -d ${STAGING_LIBDIR}/sigc++-1.2/include
19         install -m 0644 sigc++/config/sigcconfig.h ${STAGING_LIBDIR}/sigc++-1.2/include/
20         oe_libinstall -so -C sigc++ libsigc-1.2 ${STAGING_LIBDIR}
21
22         install -d ${STAGING_INCDIR}/sigc++-1.2/sigc++
23         for f in sigc++/*.h
24         do
25                 install -m 0644 $f ${STAGING_INCDIR}/sigc++-1.2/sigc++/
26         done
27 }
28