increase dvbapp PR.
[vuplus_openembedded] / recipes / libsdl / libsdl-x11_1.2.14.bb
1 # Do not use the include in 1.2.14 as it has a lot of unneeded munging that applies to old versions.
2 #require libsdl.inc
3
4 DESCRIPTION = "Simple DirectMedia Layer (X11 and Framebuffer support)"
5 SECTION = "libs"
6 PRIORITY = "optional"
7 LICENSE = "LGPL"
8 DEPENDS = "alsa-lib virtual/libgl virtual/libx11 libxext tslib"
9 DEPENDS_avr32 = "alsa-lib virtual/libx11 libxext tslib"
10 PROVIDES = "virtual/libsdl"
11 PR = "r3"
12
13 SRC_URI = " \
14   http://www.libsdl.org/release/SDL-${PV}.tar.gz \
15   file://sdl.m4 \
16 "
17
18 S = "${WORKDIR}/SDL-${PV}"
19
20 inherit autotools binconfig pkgconfig
21
22 EXTRA_OECONF = " \
23   --disable-static --disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
24   --enable-file --enable-oss --enable-alsa --disable-esd --disable-arts \
25   --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
26   --disable-mintaudio --disable-nasm --enable-video-x11 --disable-video-dga \
27   --enable-video-fbcon --disable-video-directfb --disable-video-ps2gs \
28   --disable-video-xbios --disable-video-gem --disable-video-dummy \
29   --enable-video-opengl --enable-input-events --enable-pthreads \
30   --disable-video-picogui --disable-video-qtopia --enable-dlopen \
31   --enable-input-tslib --disable-video-ps3 \
32 "
33
34 do_configure() { 
35   oe_runconf
36 }
37
38 do_configure_append () {
39   cd ${S}
40
41   # prevent libtool from linking libs against libstdc++, libgcc, ...
42   cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
43   mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
44
45   # copy new sdl.m4 macrofile to the dir for installing
46   cp ${WORKDIR}/sdl.m4 ${S}/
47 }
48
49 do_stage() {
50   autotools_stage_all           
51   rm ${STAGING_LIBDIR}/libSDL.la
52 }
53
54 FILES_${PN} = "${libdir}/lib*.so.*"
55 FILES_${PN}-dev += "${bindir}/*config"