increase dvbapp PR.
[vuplus_openembedded] / recipes / libsdl / libsdl-qpe_1.2.9.bb
1 require libsdl.inc
2
3 PR = "${INC_PR}.0"
4
5 SECTION = "opie/libs"
6 DEPENDS = "virtual/libqpe1 libopie2"
7
8 SRC_URI += "\
9   file://agawa-piro-mickey-1.2.9.patch;patch=1 \
10   file://pygame-1.2.9.patch;patch=1 \
11   file://mouse-1.2.9.patch;patch=1 \
12   file://kill-stdc++-1.2.9.patch;patch=1 \
13   file://ipaq-1.2.9.patch;patch=1 \
14   file://SDL-Akita-1.2.9.patch;patch=1 \
15   file://fixlibs-1.2.9.patch;patch=1 \
16   file://explicit-extern-C.patch;patch=1 \
17   file://no-PAGE_SIZE.patch;patch=1 \
18   file://fix_Makefile.am.patch;patch=1 \
19   file://fix_configure.in.patch;patch=1 \
20 "
21
22 EXTRA_OECONF = "--disable-static --disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
23                 --enable-file --enable-oss --disable-alsa --disable-esd --disable-arts \
24                 --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
25                 --disable-mintaudio --disable-nasm --disable-video-x11 --disable-video-dga \
26                 --enable-video-fbcon --disable-video-directfb --disable-video-ps2gs \
27                 --disable-video-xbios --disable-video-gem --disable-video-dummy \
28                 --disable-video-opengl --enable-input-events --enable-pthreads \
29                 --disable-video-picogui --enable-video-qtopia --enable-dlopen"
30
31 do_compile_prepend() {
32         if [ "${PALMTOP_USE_MULTITHREADED_QT}" == "yes" ]
33         then
34                 sed -i s,-lqte\([^-]\),-lqte-mt, src/Makefile
35         fi
36 }