change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / libsdl / libsdl-mixer_1.2.11.bb
1 DESCRIPTION = "Simple DirectMedia Layer mixer library."
2 SECTION = "libs"
3 PRIORITY = "optional"
4 DEPENDS = "virtual/libsdl flac libmikmod libvorbis libmad"
5 LICENSE = "LGPL"
6
7 PR = "r2"
8
9 SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
10            file://fix-flac-madness.diff;patch=1"
11
12 S = "${WORKDIR}/SDL_mixer-${PV}"
13
14 export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
15
16 inherit autotools_stage
17
18 # Although we build SMPEG lets not use it as it is pointless in the embedded space.
19
20 # Add support for runtime linking with libmad so we can use that for fixed point MP3 decoding.
21 # Add support for runtime linking with libtremor so we can use that for fixed point OGG Vorbis decoding.
22
23 EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor --enable-music-mp3-mad-gpl"
24
25 do_compile() {
26         # Override SDL_LIBS to include a linker rpath so the linker
27         # can find the correct libdl.so when it links playwave to
28         # libSDL_mixer.so.
29         oe_runmake SDL_LIBS="$(pkg-config sdl --libs) -Wl,-rpath-link,${STAGING_LIBDIR}"
30 }