increase dvbapp PR.
[vuplus_openembedded] / recipes / libsdl / libsdl-mixer_1.2.10.bb
1 DESCRIPTION = "Simple DirectMedia Layer mixer library."
2 SECTION = "libs"
3 PRIORITY = "optional"
4 DEPENDS = "virtual/libsdl libmikmod libvorbis"
5 LICENSE = "LGPL"
6
7 SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
8 S = "${WORKDIR}/SDL_mixer-${PV}"
9
10 export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
11
12 inherit autotools_stage
13
14 EXTRA_OECONF = "--disable-music-mp3"
15 # although we build smpeg... need to find out how
16 # to deal with optional dependencies
17
18 do_compile() {
19         # Override SDL_LIBS to include a linker rpath so the linker
20         # can find the correct libdl.so when it links playwave to
21         # libSDL_mixer.so.
22         oe_runmake SDL_LIBS="$(pkg-config sdl --libs) -Wl,-rpath-link,${STAGING_LIBDIR}"
23 }