Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / recipes / libpcap / libpcap_1.0.0.bb
1 require libpcap.inc
2
3 PR = "r6"
4 SRC_URI = "http://www.tcpdump.org/release/libpcap-${PV}.tar.gz"
5 SRC_URI += "file://aclocal.patch;patch=1"
6 SRC_URI += "file://ieee80215-arphrd.patch;patch=1"
7 SRC_URI += "file://ldflags.patch;patch=1"
8
9 do_compile () {
10     oe_runmake
11     rm -f *.o
12     oe_runmake shared
13 }
14
15 do_install () {
16     install -d ${D}${libdir}
17     install -d ${D}${bindir}
18     oe_runmake install DESTDIR=${D}
19     oe_runmake install-shared DESTDIR=${D}
20         oe_libinstall -a -so libpcap ${D}${libdir}
21 }
22
23 do_stage_append () {
24     install -d ${STAGING_INCDIR}/pcap
25     install -m 0644 pcap/pcap.h ${STAGING_INCDIR}/pcap/pcap.h
26     install -m 0644 pcap/namedb.h ${STAGING_INCDIR}/pcap/namedb.h
27     install -m 0644 pcap/bpf.h ${STAGING_INCDIR}/pcap/bpf.h
28 }
29
30