Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / libnl / libnl2_git.bb
1 DESCRIPTION = "libnl2 is a library for applications dealing with netlink sockets"
2 SECTION = "libs/network"
3 LICENSE = "LGPL"
4 HOMEPAGE = "http://people.suug.ch/~tgr/libnl"
5 PV = "1.9+gitr${SRCREV}"
6 PR = "r1"
7
8 inherit autotools
9
10 includedir = ${prefix}/include/libnl2
11
12 SRC_URI = "\
13   git://git.kernel.org/pub/scm/libs/netlink/libnl.git;protocol=git \
14   file://fix-pc-file.patch;patch=1 \
15 "
16 S = "${WORKDIR}/git"
17
18 PACKAGES =+ "${PN}-route ${PN}-nf ${PN}-genl ${PN}-cli"
19 FILES_${PN}-route = "${libdir}/libnl-route.so.*"
20 FILES_${PN}-nf    = "${libdir}/libnl-nf.so.*"
21 FILES_${PN}-genl  = "${libdir}/libnl-genl.so.*"
22 FILES_${PN}-cli   = "${libdir}/libnl-cli.so.*"