increase dvbapp PR.
[vuplus_openembedded] / recipes / libiconv / libiconv_1.11.bb
1 DESCRIPTION = "GNU libiconv - libiconv is for you if your application needs to support \
2 multiple character encodings, but that support lacks from your system."
3 HOMEPAGE = "http://www.gnu.org/software/libiconv"
4 SECTION = "libs"
5 PRIORITY = "optional"
6 NOTES = "Needs to be stripped down to: ascii iso8859-1 eucjp iso-2022jp gb utf8"
7 PROVIDES = "virtual/libiconv"
8 PR = "r4"
9 LICENSE = "LGPL"
10 SRC_URI = "ftp://ftp.gnu.org/pub/gnu/libiconv/libiconv-${PV}.tar.gz"
11
12 S = "${WORKDIR}/libiconv-${PV}"
13
14 inherit autotools pkgconfig
15
16 EXTRA_OECONF += "--enable-shared --enable-static --enable-relocatable"
17
18 do_configure () {
19         rm -f m4/libtool.m4 libcharset/m4/libtool.m4
20         autotools_do_configure
21
22         # As we do not really regenerate the Makefiles... and they have stale deps to this file
23         touch m4/libtool.m4
24
25         # Fix stupid libtool... handling. rpath handling can't be disabled and the Makefile's can't be regenerated..
26         # (GNU sed required)
27         sed -i s/^hardcode_libdir_flag_spec/#hardcode_libdir_flag_spec/ ${S}/*-libtool
28 }
29
30 do_stage () {
31         oe_libinstall -so -a -C lib libiconv ${STAGING_LIBDIR}
32         oe_libinstall -so -C lib libiconv_plug_linux ${STAGING_LIBDIR}
33         oe_libinstall -so -a -C libcharset/lib libcharset ${STAGING_LIBDIR}
34         autotools_stage_includes
35 }