increase dvbapp PR.
[vuplus_openembedded] / recipes / libelf / libelf_0.8.6.bb
1 DESCRIPTION = "libelf is an ELF object file access library. \
2 The elf library provides routines to access, and manipulate, Elf object files."
3 LICENSE = "LGPL"
4 SECTION = "libs"
5 PR = "r1"
6
7 SRC_URI = "http://www.mr511.de/software/libelf-${PV}.tar.gz \
8            http://www.stud.uni-hannover.de/~michael/software/libelf-${PV}.tar.gz"
9
10 inherit autotools
11
12 PARALLEL_MAKE = ""
13
14 TARGET_CC_ARCH += "${LDFLAGS}"
15
16 do_configure_prepend () {
17         if test ! -e acinclude.m4; then
18                 cp aclocal.m4 acinclude.m4
19         fi
20 }
21
22 do_install () {
23         oe_runmake 'prefix=${D}${prefix}' 'exec_prefix=${D}${exec_prefix}' \
24                    'libdir=${D}${libdir}' 'includedir=${D}${includedir}' \
25                    install
26 }
27
28 do_stage () {
29         oe_libinstall -so -C lib libelf ${STAGING_LIBDIR}/
30         install -d ${STAGING_INCDIR}/libelf
31         for i in libelf.h nlist.h gelf.h sys_elf.h; do
32                 install -m 0644 lib/$i ${STAGING_INCDIR}/libelf/
33         done
34         make includedir=${STAGING_INCDIR} install-compat
35 }