Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / libcwd / libcwd_0.99.47.bb
1 DESCRIPTION = "Libcwd is a thread-safe, full-featured debugging support library for C++ developers. \
2 It includes ostream-based debug output with custom debug channels and devices, \
3 powerful memory allocation debugging support, as well as run-time support for \
4 printing source line number information and demangled type names."
5 SECTION = "devel/libs"
6 LICENSE = "QPL"
7 HOMEPAGE = "http://libcwd.sourceforge.net"
8 PR = "r0"
9
10 SRC_URI = "${SOURCEFORGE_MIRROR}/libcwd/libcwd-${PV}.tar.gz"
11
12 inherit autotools pkgconfig
13
14 do_configure() {
15         gnu-configize
16         oe_runconf
17 }
18
19 do_stage() {
20         autotools_stage_all
21 }
22
23 PARALLEL_MAKE = ""
24
25 PACKAGES =+ "${PN}-config ${PN}-mt"
26 FILES_${PN} = "${libdir}/libcwd.so*"
27 FILES_${PN}-mt = "${libdir}/libcwd_r.so*"
28 FILES_${PN}-config = "${datadir}"
29 RRECOMMENDS_${PN} = "${PN}-config"
30 RRECOMMENDS_${PN}-mt = "${PN}-config"