increase dvbapp PR.
[vuplus_openembedded] / recipes / libcdio / libcdio_0.80.bb
1 DESCRIPTION = "A library to encapsulate CD-ROM reading and control"
2 HOMEPAGE = "http://www.gnu.org/software/libcdio/"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 MAINTAINER = "Andreas Frisch <andreas.frisch@multimedia-labs.de>"
7 PR="r1"
8 DEPENDS = "libcddb"
9
10 SRC_URI = "http://ftp.gnu.org/pub/gnu/libcdio/${PN}-${PV}.tar.gz\
11             file://${PN}-${PV}-configure-crosscompile.patch;patch=1\
12             file://${PN}-${PV}-minimal-new.patch;patch=1\
13             file://${PN}-${PV}-fix-pkgconfig.patch;patch=1\
14             file://${PN}-${PV}-add-cdtextinfo.patch;patch=1"
15
16 inherit pkgconfig autotools
17
18 EXTRA_OECONF="--enable-cddb --disable-cpp-progs --disable-vcd-info --disable-maintainer-mode --without-cd-paranoia --without-cdda-player --disable-cxx --disable-example-progs --disable-joliet --without-cd-drive --without-cd-read --without-iso-info --without-iso-read --without-cd-info"
19
20 DEPENDS = "libcddb virtual/libintl"
21
22 do_compile_append () {
23         install -d ${D}${bindir}
24         install -m 0755 ${S}/src/.libs/cdtextinfo ${D}${bindir}
25 }
26
27 do_stage () {
28         oe_libinstall -so -C lib libcdio ${STAGING_LIBDIR}
29         install -d ${STAGING_INCDIR}/cdio
30         install -m 0644  ${S}/include/cdio/*.h ${STAGING_INCDIR}/cdio
31 }