Merge remote-tracking branch 'dm/opendreambox-1.6' into test_0701
[vuplus_openembedded] / recipes / libcddb / libcddb_1.3.0_r1.bb
1 DESCRIPTION = "A library for accessing a CDDB server"
2 HOMEPAGE = "http://libcddb.sourceforge.net"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "LGPL-2"
6 MAINTAINER = "Andreas Frisch <andreas.frisch@multimedia-labs.de>"
7
8 SRC_URI = "http://downloads.sourceforge.net/${PN}/${PN}-${PV}.tar.bz2\
9             file://${P}-configure-realloc.patch;patch=1\
10             file://${P}-asneeded-nonglibc.patch;patch=1"
11
12 #EXTRA_OECONF = "--without-cdio --without-iconv"
13
14 inherit autotools pkgconfig
15
16 DEPEND="doc? ( app-doc/doxygen )"
17
18 do_stage () {
19         oe_libinstall -so -C lib libcddb ${STAGING_LIBDIR}
20         install -d ${STAGING_INCDIR}/cddb
21         install -m 0644  ${S}/include/cddb/*.h ${STAGING_INCDIR}/cddb
22 }