increase dvbapp PR.
[vuplus_openembedded] / recipes / knights / knights_1.14.bb
1 DESCRIPTION = "Chess Game for Qt/Embedded based palmtop environments. \
2 Uses the Phalanx chess engine."
3 SECTION = "opie/games"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "phalanx"
7 RDEPENDS = "phalanx"
8 PR = "r2"
9
10 SRC_URI = "http://www.openzaurus.org/mirror/knights.tar.gz \
11            file://libqpe-opie.patch;patch=1 \
12            file://gcc3.patch;patch=1"
13 S = "${WORKDIR}/knights"
14
15 inherit palmtop
16
17 QMAKE_PROFILES = "knights.pro"
18
19 do_configure_prepend() {
20         printf "TEMPLATE=subdirs\nSUBDIRS=qtcompat microkde knights\n" >knights.pro
21 }
22
23 do_install() {
24         install -d ${D}${palmtopdir}/bin \
25                    ${D}${palmtopdir}/apps/Games \
26                    ${D}${palmtopdir}/pics
27         install -D -m 755 knights/knights ${D}${palmtopdir}/bin/knights
28         install -D -m 644 knights.desktop ${D}${palmtopdir}/apps/Games/knights.desktop
29         install -d ${D}${palmtopdir}/pics
30         cp -pPR pics/knights ${D}${palmtopdir}/pics/
31 }