Merge branch 'opendreambox' of git://git.opendreambox.org/git/openembedded into opend...
[vuplus_openembedded] / recipes / keylaunch / keylaunch_2.0.10.bb
1 inherit gpe
2
3 DEPENDS = "virtual/xserver libxtst libxau libxpm libgpelaunch keylaunch-conf"
4 RDEPENDS = "keylaunch-conf"
5
6 SECTION = "gpe"
7 LICENSE = "GPL"
8 DESCRIPTION = "A small utility for binding commands to a hot key.\
9  Keylaunch is a minimal utility for associating commands with hot keys. This\
10  GPE version is intended for use with the special keys found on most handheld\
11  computers. You can connect each key to a program of your choice; if the\
12  program is already running, keylaunch can bring its window to the front\
13  rather than just running another copy."
14 PR = "r14"
15
16 SRC_URI += " file://makefile-fix.patch;patch=1 file://unbreak-keyevents.patch;patch=1"
17
18 export CVSBUILD="no"
19
20 do_install_append() {
21         # Remove random crap
22         rm ${D}/etc/keylaunchrc
23         rm -rf ${D}/etc/X11/Xinit.d/
24 }