increase dvbapp PR.
[vuplus_openembedded] / recipes / kexecboot / linux-kexecboot_2.6.29.bb
1 require linux-kexecboot.inc
2
3 COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm|omap3-pandora|overo|omapzoom"
4
5 SRCREV = "58cf2f1425abfd3a449f9fe985e48be2d2555022"
6
7 # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
8 PR_append = "+gitr${SRCREV}"
9
10 SRC_URI += "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
11            file://defconfig"
12
13 SRC_URI_append = " \
14            file://no-empty-flash-warnings.patch;patch=1 \
15            file://no-cortex-deadlock.patch;patch=1 \
16            file://read_die_ids.patch;patch=1 \
17            file://fix-install.patch;patch=1 \
18            file://dss2/0001-Revert-gro-Fix-legacy-path-napi_complete-crash.patch;patch=1 \
19            file://dss2/0002-OMAPFB-move-omapfb.h-to-include-linux.patch;patch=1 \
20            file://dss2/0003-DSS2-OMAP2-3-Display-Subsystem-driver.patch;patch=1 \
21            file://dss2/0004-DSS2-OMAP-framebuffer-driver.patch;patch=1 \
22            file://dss2/0005-DSS2-Add-panel-drivers.patch;patch=1 \
23            file://dss2/0006-DSS2-HACK-Add-DSS2-support-for-N800.patch;patch=1 \
24            file://dss2/0007-DSS2-Add-DSS2-support-for-SDP-Beagle-Overo-EVM.patch;patch=1 \
25            file://dss2/0008-DSS2-Add-function-to-display-object-to-get-the-back.patch;patch=1 \
26            file://dss2/0009-DSS2-Add-acx565akm-panel.patch;patch=1 \
27            file://dss2/0010-DSS2-Small-VRFB-context-allocation-bug-fixed.patch;patch=1 \
28            file://dss2/0011-DSS2-Allocated-memory-for-Color-Look-up-table.patch;patch=1 \
29            file://dss2/0012-DSS2-Fix-DMA-rotation.patch;patch=1 \
30            file://dss2/0013-DSS2-Verify-that-overlay-paddr-0.patch;patch=1 \
31            file://dss2/0014-DSS2-Add-function-to-get-DSS-logic-clock-rate.patch;patch=1 \
32            file://dss2/0015-DSS2-DSI-calculate-VP_CLK_RATIO-properly.patch;patch=1 \
33            file://dss2/0016-DSS2-DSI-improve-packet-len-calculation.patch;patch=1 \
34            file://dss2/0017-DSS2-Disable-video-planes-on-sync-lost-error.patch;patch=1 \
35            file://dss2/0018-DSS2-check-for-ovl-paddr-only-when-enabling.patch;patch=1 \
36            file://dss2/0019-DSS2-Check-fclk-limits-when-configuring-video-plane.patch;patch=1 \
37            file://dss2/0020-DSS2-Check-scaling-limits-against-proper-values.patch;patch=1 \
38            file://dss2/0021-DSS2-Add-venc-register-dump.patch;patch=1 \
39            file://dss2/0022-DSS2-FB-remove-unused-var-warning.patch;patch=1 \
40            file://dss2/0023-DSS2-pass-the-default-FB-color-format-through-board.patch;patch=1 \
41            file://dss2/0024-DSS2-Beagle-Use-gpio_set_value.patch;patch=1 \
42            file://dss2/0025-DSS2-VRFB-Macro-for-calculating-base-address-of-th.patch;patch=1 \
43            file://dss2/0026-DSS2-DSI-sidlemode-to-noidle-while-sending-frame.patch;patch=1 \
44            file://dss2/0027-DSS2-VRFB-rotation-and-mirroring-implemented.patch;patch=1 \
45            file://dss2/0028-DSS2-OMAPFB-Added-support-for-the-YUV-VRFB-rotatio.patch;patch=1 \
46            file://dss2/0029-DSS2-OMAPFB-Set-line_length-correctly-for-YUV-with.patch;patch=1 \
47            file://dss2/0030-DSS2-dispc_get_trans_key-was-returning-wrong-key-ty.patch;patch=1 \
48            file://dss2/0031-DSS2-do-bootmem-reserve-for-exclusive-access.patch;patch=1 \
49            file://dss2/0032-DSS2-Fix-DISPC_VID_FIR-value-for-omap34xx.patch;patch=1 \
50            file://dss2/0033-DSS2-Prefer-3-tap-filter.patch;patch=1 \
51            file://dss2/0034-DSS2-VRAM-improve-omap_vram_add_region.patch;patch=1 \
52            file://dss2/0035-DSS2-Added-the-function-pointer-for-getting-default.patch;patch=1 \
53            file://dss2/0036-DSS2-Added-support-for-setting-and-querying-alpha-b.patch;patch=1 \
54            file://dss2/0037-DSS2-Added-support-for-querying-color-keying.patch;patch=1 \
55            file://dss2/0038-DSS2-OMAPFB-Some-color-keying-pointerd-renamed-in-D.patch;patch=1 \
56            file://dss2/0039-DSS2-Add-sysfs-entry-to-for-the-alpha-blending-supp.patch;patch=1 \
57            file://dss2/0040-DSS2-Provided-proper-exclusion-for-destination-colo.patch;patch=1 \
58            file://dss2/0041-DSS2-Disable-vertical-offset-with-fieldmode.patch;patch=1 \
59            file://dss2/0042-DSS2-Don-t-enable-fieldmode-automatically.patch;patch=1 \
60            file://dss2/0043-DSS2-Swap-field-0-and-field-1-registers.patch;patch=1 \
61            file://dss2/0044-DSS2-add-sysfs-entry-for-seting-the-rotate-type.patch;patch=1 \
62            file://dss2/0045-DSS2-Fixed-line-endings-from-to.patch;patch=1 \
63            file://dss2/0046-DSS2-DSI-decrease-sync-timeout-from-60s-to-2s.patch;patch=1 \
64            file://dss2/0047-DSS2-fix-return-value-for-rotate_type-sysfs-functio.patch;patch=1 \
65            file://dss2/0048-OMAP2-3-DMA-implement-trans-copy-and-const-fill.patch;patch=1 \
66            file://dss2/0049-DSS2-VRAM-clear-allocated-area-with-DMA.patch;patch=1 \
67            file://dss2/0050-DSS2-OMAPFB-remove-fb-clearing-code.patch;patch=1 \
68            file://dss2/0051-DSS2-VRAM-use-debugfs-not-procfs.patch;patch=1 \
69            file://dss2/0052-DSS2-VRAM-fix-section-mismatch-warning.patch;patch=1 \
70            file://dss2/0053-DSS2-disable-LCD-DIGIT-before-resetting-DSS.patch;patch=1 \
71            file://dss2/0054-DSS2-DSI-more-error-handling.patch;patch=1 \
72            file://dss2/0055-DSS2-Added-global-alpha-support.patch;patch=1 \
73            file://dss2/0056-DSS2-Rotation-attrs-for-YUV-need-not-to-be-reversed.patch;patch=1 \
74            file://dss2/0057-DSS2-Documentation-update-for-new-sysfs-entries-in.patch;patch=1 \
75            file://dss2/0058-DSS2-Don-t-touch-plane-coordinates-when-changing-fb.patch;patch=1 \
76            file://dss2/0059-DSS2-DSI-configure-ENTER-EXIT_HS_MODE_LATENCY.patch;patch=1 \
77            file://dss2/0060-DSS2-Avoid-div-by-zero-when-calculating-required-fc.patch;patch=1 \
78            file://dss2/0061-DSS2-VRFB-save-restore-context.patch;patch=1 \
79            file://dss2/0062-DSS2-VRAM-Fix-indentation.patch;patch=1 \
80            file://dss2/0063-DSS2-fix-the-usage-of-get_last_off_on_transaction_i.patch;patch=1 \
81            file://dss2/0064-VRFB-fix-debug-messages.patch;patch=1 \
82            file://dss2/0065-VRFB-add-suspend-resume-functionality.patch;patch=1 \
83            file://dss2/0066-DSS2-DSI-tune-the-timings-to-be-more-relaxed.patch;patch=1 \
84            file://dss2/0067-DSS2-VRFB-don-t-WARN-when-releasing-inactive-ctx.patch;patch=1 \
85            file://dss2/0068-DSS2-Swap-field-offset-values-w-VRFB-rotation.patch;patch=1 \
86            file://dss2/0069-DSS2-OMAP3EVM-Added-DSI-powerup-and-powerdown-func.patch;patch=1 \
87            file://dss2/0070-DSS2-fix-irq1.diff;patch=1 \
88            file://dss2/0071-DSS2-fix-irq2.diff;patch=1 \
89            file://0001-board-ldp-add-regulator-info-to-get-the-microSD-slo.patch;patch=1 \
90            file://fix-unaligned-access.diff;patch=1 \
91            file://make-alignment-visible.diff;patch=1 \
92            file://mmctiming.patch;patch=1 \
93            file://ehci.patch;patch=1 \
94            file://fix-audio-capture.patch;patch=1 \
95            file://ads7846-detection.patch;patch=1 \
96            file://musb/0001-USB-musb-only-turn-off-vbus-in-OTG-hosts.patch;patch=1 \
97            file://musb/0002-USB-composite-avoid-inconsistent-lock-state.patch;patch=1 \
98            file://musb/0003-USB-musb-NAK-timeout-scheme-on-bulk-RX-endpoint.patch;patch=1 \
99            file://musb/0004-USB-musb-rewrite-host-periodic-endpoint-allocation.patch;patch=1 \
100            file://musb/0005-USB-TWL-disable-VUSB-regulators-when-cable-unplugg.patch;patch=1 \
101            file://musb/0006-USB-gadget-composite-device-level-suspend-resume-h.patch;patch=1 \
102            file://musb/0007-usb-gadget-fix-ethernet-link-reports-to-ethtool.patch;patch=1 \
103            file://musb/0008-usb-musb_host-minor-enqueue-locking-fix-v2.patch;patch=1 \
104            file://musb/0009-usb-musb_host-fix-ep0-fifo-flushing.patch;patch=1 \
105            file://musb/0010-musb-sanitize-clearing-TXCSR-DMA-bits-take-2.patch;patch=1 \
106            file://musb/0011-musb-fix-isochronous-TXDMA-take-2.patch;patch=1 \
107            file://musb/0012-musb-fix-possible-panic-while-resuming.patch;patch=1 \
108            file://musb/0013-musb_host-refactor-musb_save_toggle-take-2.patch;patch=1 \
109            file://musb/0014-musb_gadget-suppress-parasitic-TX-interrupts-with.patch;patch=1 \
110            file://musb/0015-musb_gadget-fix-unhandled-endpoint-0-IRQs.patch;patch=1 \
111            file://musb/0016-musb_host-factor-out-musb_ep_-get-set-_qh.patch;patch=1 \
112            file://musb/0017-musb_host-refactor-URB-giveback.patch;patch=1 \
113            file://musb/0018-musb-split-out-CPPI-interrupt-handler.patch;patch=1 \
114            file://musb/0019-musb_host-simplify-check-for-active-URB.patch;patch=1 \
115            file://musb/0020-musb_host-streamline-musb_cleanup_urb-calls.patch;patch=1 \
116            file://musb/0021-twl4030-usb-fix-minor-reporting-goofage.patch;patch=1 \
117            file://musb/0022-musb-use-dma-mode-1-for-TX-if-transfer-size-equals.patch;patch=1 \
118            file://musb/0023-musb-add-high-bandwidth-ISO-support.patch;patch=1 \
119            file://musb/0024-USB-otg-adding-nop-usb-transceiver.patch;patch=1 \
120            file://musb/0025-nop-usb-xceiv-behave-when-linked-as-a-module.patch;patch=1 \
121            file://musb/0026-musb-proper-hookup-to-transceiver-drivers.patch;patch=1 \
122            file://musb/0027-musb-otg-timer-cleanup.patch;patch=1 \
123            file://musb/0028-musb-make-initial-HNP-roleswitch-work-v2.patch;patch=1 \
124            file://musb/0029-musb-support-disconnect-after-HNP-roleswitch.patch;patch=1 \
125            file://isp/v4l/0001-V4L2-Add-COLORFX-user-control.patch;patch=1 \
126            file://isp/v4l/0002-V4L-Int-if-v4l2_int_device_try_attach_all-requires.patch;patch=1 \
127            file://isp/v4l/0003-V4L-Int-if-Dummy-slave.patch;patch=1 \
128            file://isp/v4l/0004-V4L-int-device-add-support-for-VIDIOC_QUERYMENU.patch;patch=1 \
129            file://isp/v4l/0005-V4L-Int-if-Add-vidioc_int_querycap.patch;patch=1 \
130            file://isp/iommu/0001-omap-iommu-tlb-and-pagetable-primitives.patch;patch=1 \
131            file://isp/iommu/0002-omap-iommu-omap2-architecture-specific-functions.patch;patch=1 \
132            file://isp/iommu/0003-omap-iommu-omap3-iommu-device-registration.patch;patch=1 \
133            file://isp/iommu/0004-omap-iommu-simple-virtual-address-space-management.patch;patch=1 \
134            file://isp/iommu/0005-omap-iommu-entries-for-Kconfig-and-Makefile.patch;patch=1 \
135            file://isp/iommu/0006-omap-iommu-Don-t-try-BUG_ON-in_interrupt.patch;patch=1 \
136            file://isp/iommu/0007-omap-iommu-We-support-chained-scatterlists-probabl.patch;patch=1 \
137            file://isp/iommu/0008-omap2-iommu-entries-for-Kconfig-and-Makefile.patch;patch=1 \
138            file://isp/omap3camera/0001-omap3isp-Add-ISP-main-driver-and-register-definitio.patch;patch=1 \
139            file://isp/omap3camera/0002-omap3isp-Add-ISP-MMU-wrapper.patch;patch=1 \
140            file://isp/omap3camera/0003-omap3isp-Add-userspace-header.patch;patch=1 \
141            file://isp/omap3camera/0004-omap3isp-Add-ISP-frontend-CCDC.patch;patch=1 \
142            file://isp/omap3camera/0005-omap3isp-Add-ISP-backend-PRV-and-RSZ.patch;patch=1 \
143            file://isp/omap3camera/0006-omap3isp-Add-statistics-collection-modules-H3A-and.patch;patch=1 \
144            file://isp/omap3camera/0007-omap3isp-Add-CSI2-interface-support.patch;patch=1 \
145            file://isp/omap3camera/0008-omap3isp-Add-ISP-tables.patch;patch=1 \
146            file://isp/omap3camera/0009-omap34xxcam-Add-camera-driver.patch;patch=1 \
147            file://isp/resizer/0023-OMAP-Resizer-Basic-Resizer-refreshed-with-latest-gi.patch;patch=1 \
148            file://isp/resizer/0024-OMAP3-Resizer-V4L2-buf-layer-issues-fixed.patch;patch=1 \
149            file://isp/resizer/0025-OMAP3-Resizer-Build-issues-fixed.patch;patch=1 \
150            file://0124-leds-gpio-broken-with-current-git.patch;patch=1 \
151            file://modedb-hd720.patch;patch=1 \
152            file://0001-implement-TIF_RESTORE_SIGMASK-support-and-enable-the.patch;patch=1 \
153            file://vfp/02-vfp-ptrace.patch;patch=1 \
154            file://vfp/03-vfp-corruption.patch;patch=1 \
155            file://vfp/04-vfp-threads.patch;patch=1 \
156            file://vfp/05-vfp-signal-handlers.patch;patch=1 \
157 "
158
159
160 SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \
161                                            file://beagle-asoc.patch;patch=1 \
162                                file://tincantools-puppy.diff;patch=1 \
163 "
164
165 SRC_URI_append_omap3evm = " \
166         file://evm-mcspi-ts.diff;patch=1 \
167 "
168
169 S = "${WORKDIR}/git"
170
171