Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / kexecboot / initramfs-kexecboot-image.bb
1 # Initramfs image providing kexecboot
2 # a linux as bootloader implementation
3 PR = "r2"
4
5 ONLINE_PACKAGE_MANAGEMENT = "none"
6 IMAGE_FSTYPES = "cpio.gz cpio.lzma"
7 DEPENDS = "lzma-native"
8
9 # Deprecated: device nodes are populated by kexecboot now
10 # These devices need mmcblk* to be 254 instead of 179
11 IMAGE_DEVICE_TABLES_hx4700 = "device_table-oldmmc.txt"
12 IMAGE_DEVICE_TABLES_h2200 = "device_table-oldmmc.txt"
13
14 export IMAGE_BASENAME = "initramfs-kexecboot-image"
15
16 # avoid circular dependencies
17 EXTRA_IMAGEDEPENDS = ""
18
19 IMAGE_INSTALL = "kexecboot"
20
21 IMAGE_LINGUAS = ""
22 IMAGE_LOGIN_MANAGER = ""
23 IMAGE_INIT_MANAGER = ""
24 IMAGE_INITSCRIPTS = ""
25 IMAGE_DEV_MANAGER = ""
26
27 inherit image