increase dvbapp PR
[vuplus_openembedded] / recipes / kexec-tools / kexec-tools-klibc-static_1.101.bb
1 # the binaries are statical linked against klibc
2 require kexec-tools.inc
3
4 PR = "r8"
5 DEPENDS = "klibc"
6
7 SRC_URI += "file://kexec-static.patch;patch=1 \
8             file://kexec-klibc.patch;patch=1 \
9             "
10 S = "${WORKDIR}/kexec-tools-${PV}"
11
12 EXTRA_OECONF = " --without-zlib"
13
14 # reset inherited OE flags to avoid e.g. ggdb3 and keep size small
15 export CFLAGS=""
16 export CPPFLAGS=""
17 export LDFLAGS=""
18
19 export CC=${TARGET_PREFIX}klcc
20
21 PACKAGES =+ "kexec-klibc-static kdump-klibc-static"
22
23 FILES_kexec-klibc-static = "${sbindir}/kexec"
24 FILES_kdump-klibc-static = "${sbindir}/kdump"