Merge branch 'opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / kaffe / kaffeh-native_cvs.bb
1 PV = "1.1.5+cvs${SRCDATE}"
2 DEFAULT_PREFERENCE = "-1"
3 PR = "r3"
4
5 SRC_URI = "cvs://readonly:readonly@cvs.kaffe.org/cvs/kaffe;module=kaffe"
6 S = "${WORKDIR}/kaffe"
7
8 require kaffe.inc
9
10 inherit native
11
12 EXTRA_OECONF = "--disable-alsatest \
13         --disable-esdtest \
14         --disable-sound \
15         --with-jikes \
16         --without-classpath-gtk-awt \
17         --without-gmp \
18         --enable-pure-java-math \
19         --disable-native-awt \
20         --disable-sound \
21         --without-x \
22         --without-kaffe-x-awt \
23         --disable-debug \
24         --disable-gcj"
25
26 do_stage() {
27         install -m 0755 kaffe/kaffeh/kaffeh ${STAGING_BINDIR}/
28
29         install -d ${STAGING_DATADIR}/kaffeh
30         install -m 0755 libraries/javalib/*.jar ${STAGING_DATADIR}/kaffeh/
31 }
32