increase dvbapp PR.
[vuplus_openembedded] / recipes / jpeg / jpeg_8b.bb
1 DESCRIPTION = "libjpeg is a library for handling the JPEG (JFIF) image format."
2 LICENSE = "jpeg"
3 SECTION = "libs"
4 PRIORITY = "required"
5 PR = "r1"
6
7 # TODO: really needed?
8 RPROVIDES_${PN} = "jpeg"
9
10 SRC_URI = "\
11     http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
12     file://0001-configure-make-jpeg-work-with-older-autotools.patch \
13     "
14 SRC_URI_append_vuplus = " file://configure-define-AM-SILENT-RULES.patch;patch=1;pnum=1"
15 S = "${WORKDIR}/jpeg-${PV}"
16
17 inherit autotools
18
19 EXTRA_OECONF = "--enable-static --enable-shared"
20 CFLAGS_append = " -D_REENTRANT"
21
22 PACKAGES =+ "${PN}-tools "
23 FILES_${PN}-tools = "${bindir}/*"
24
25 BBCLASSEXTEND = "native"
26
27 SRC_URI[md5sum] = "e022acbc5b36cd2cb70785f5b575661e"
28 SRC_URI[sha256sum] = "36e6208edec591bae8f2fc370ea4f991447badb6377a125c211ffa7b503174a7"