increase dvbapp PR.
[vuplus_openembedded] / recipes / javasqlite / javasqlite-mkconst-native_20080130.bb
1 DESCRIPTION = "mkcons program needed for javasqlite build"
2 HOMEPAGE = "http://www.ch-werner.de/javasqlite"
3 LICENSE  = "BSD"
4
5 DEPENDS = "sqlite-native sqlite3-native"
6
7 SRC_URI = "\
8   http://www.ch-werner.de/javasqlite/javasqlite-${PV}.tar.gz \
9   file://build-fix.patch;patch=1"
10
11 S = "${WORKDIR}/javasqlite-${PV}"
12
13 inherit autotools native
14
15 # Program names are there to fool configure checks
16 # because we actually do not need these.
17 EXTRA_OECONF = " \
18   --with-sqlite-incdir=${STAGING_INCDIR} \
19   --with-sqlite-libdir=${STAGING_LIBDIR} \
20   --with-sqlite3-incdir=${STAGING_INCDIR} \
21   --with-sqlite3-libdir=${STAGING_LIBDIR} \
22   --with-jardir=${datadir_java} \
23   --with-native-libdir=${libdir_jni} \
24         --with-java='echo version 1.5' \
25         --with-javac=true \
26         --with-jar=true \
27         --with-javah=true \
28         --with-javadoc=true \
29         "
30
31 do_configurepre() {
32   sed -i -e "s|wrong-libtool|${BUILD_SYS}-libtool|" Makefile.in
33 }
34
35 addtask configurepre after do_patch before do_configure
36
37
38 do_compile() {
39         oe_runmake native/mkconst
40 }
41
42 do_install() {
43         :
44 }
45
46 do_stage() {
47         install -d ${STAGING_BINDIR}
48         install -m 0755 native/.libs/mkconst ${STAGING_BINDIR}/javasqlite-mkconst-${PV}
49 }
50
51 PACKAGES = ""
52