increase dvbapp PR.
[vuplus_openembedded] / recipes / jakarta-libs / poi_3.0.bb
1 DESCRIPTION = "Java library for manipulating various file formats based upon Microsoft's OLE 2 Compound Document"
2 LICENSE = "AL2.0"
3 AUTHOR = "Apache Software Foundation"
4
5 SRC_URI = "http://www.apache.org/dist/jakarta/poi/release/src/${BPN}-src-${PV}-FINAL-20070503.tar.gz"
6
7 S = "${WORKDIR}/${BPN}-3.0-rc4"
8
9 inherit java-library
10
11 DEPENDS = "fastjar-native commons-collections3 commons-logging commons-lang commons-beanutils log4j1.2 xalan-j"
12
13 do_compile() {
14   mkdir -p build
15
16   oe_makeclasspath cp -s commons-collections3 commons-logging commons-lang commons-beanutils log4j-1.2 xalan2
17
18   javac -sourcepath src/java -cp $cp -d build \
19     `find src/java -name \*.java`
20
21   (cd src/java && find . -name "*.properties" -exec cp {} ../../build/{} \;)
22
23   fastjar -C build -c -f ${JARFILENAME} .
24 }